Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

'Page Name not defined' in page title reports - Outlinks being tracked as pages #5113

Closed
anonymous-piwik-user opened this Issue · 3 comments

2 participants

@anonymous-piwik-user

Since 2.2.1 there is a line with 'page name not defined' in my stats. (today's update 2.2.2 did not solve this)
It shows up in the page title report on my dashboard as well as the page title report in the actions tab.

I have checked the entire visitor log and the visitors in real time widget. In these reports all pages have a normal page name, there are no instances of 'page name not defined'.

Here is the line:

Page Name not defined   295     86  0%  0s  0%  -
Page X  95  73  26%     3 min 45s   60%     0.91s

It doesn't show statistics for 'time spend on page', 'exit rate' or 'page generation time', which I think is weird as all my other pages have a normal value for these items.

At first I thought that maybe the goals where being tracked as pages, but the number of conversions is lower (173 conversions/clicks by 67 visitors)

After a closer inspection I noticed that the number of outlinks is the same (295 outlinks, 263 unique outlinks).
Looking at the visitor log again, I see nothing out of the ordinary: outlinks have the typical image in front of them.

As I have two separate installs of piwik (one for the live site and one for development), I have checked if both show the same behaviour, and yes after updating both of them to the latest Piwik version: Outlinks are being tracked as internal pages with 'page name not defined' on both installs.

I hope there is a quick fix for this.

@mattab
Owner

Thanks for the report, that's a regression in 2.2.2

@mattab
Owner

In 1bf9a20: Refs #5113 This may fix the bug where Outlinks are marked as "Page name not defined".
Let's see which integration tests now fail

@mattab
Owner

In dec86d0: Fixes #5113 Updating integration test after the bug was fixed!

@sabl0r sabl0r referenced this issue from a commit in sabl0r/piwik
@mattab mattab Refs #5113 This may fix the bug where Outlinks are marked as "Page na…
…me not defined".

Let's see which integration tests now fail
1bf9a20
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.