Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Version 2.2.2: Dashboard "Length of Visits" widget, Pie Chart incorrect % calculation #5116

Closed
canajun2eh opened this Issue · 11 comments

2 participants

@canajun2eh

In the 2.2.2 Dashboard "Length of Visits" pie chart, when you hover over one of the pie segments, the % of visits always shows as 0%. The % of visits is correct when the widget is configured for bar graphs.

@canajun2eh

The same problem exists in the Dashboard "Visits by Server Time" widget. When this widget is configured for Pie Chart, hovering over any of the pie segments shows 0%. When the widget is configured for bar graph, the % of visits is correct.

I suspect the same problem might exist in other places where the Pie Chart is a display option.

@tsteur
Owner

Hi canajun2eh,

do you get this error also in other reports when using Pie charts? For instance in Referrers? I tried to reproduce it but it worked for me.

Do you see this issue on http://demo.piwik.org/ ?

@canajun2eh

In my Piwik 2.2.2 installation, I see the problem in the "Visits by Server Time" and in the "Length of Visits" pie charts. I do not see it in the "Search Engines", "Visits by Server Time", "Visitor Browser" or the "Visitor Location (City)" pie charts. It appears that my supposition of "all pie charts" is wrong.

When I delete these widgets from my dashboard and then re-activate them, the two incorrect pie charts still show the same problem.

I do not see the problem on the Piwik demo.

If you need credentials to access my Piwik installation, please let me know by e-mail.

@tsteur
Owner

Credentials would be great! View permission should be enough for a first debugging session. Can you send us the credentials to hello @ piwik.org and leave a short comment here afterwards (in case the mail goes into the spam folder)?

@canajun2eh

Credentials with "View" rights to the 4 sites I'm tracking were sent to the above e-mail address as requested.

Please let me know if you need more rights, or even FTP access.

@canajun2eh

The Login credentials were deleted yesterday. They were not used.

@tsteur
Owner

I'm sorry I somehow didn't notice your comment. I'd be glad to check it if you don't mind you setup the credentials again. Sorry!

@canajun2eh

I've set up Login credentials again.

Details are in an e-mail I just sent to hello @ piwik.org (without those spaces, of course)

@tsteur
Owner

In 5d859cb: fixes #5116 fixes percentages in chart tooltips are sometimes 0% although they should not. Happened when there was a value 0 in value[1] meaning there was no data for one of the points. In such a case sum was the value of the concatenated array such as "0-5:3,5-10:10,...

@tsteur
Owner

Thx a lot! I found the issue and fixed it. Should work for you in the next release. No longer need the credentials

@canajun2eh

Thank you.

This was obviously not a critical issue. More along the lines of "cosmetic".

@canajun2eh canajun2eh added this to the 2.3.0 - Piwik 2.3.0 milestone
@tsteur tsteur was assigned by canajun2eh
@fhemberger fhemberger referenced this issue from a commit
@tsteur tsteur fixes #5116 fixes percentages in chart tooltips are sometimes 0% alth…
…ough they should not. Happened when there was a value 0 in value[1] meaning there was no data for one of the points. In such a case sum was the value of the concatenated array such as "0-5:3,5-10:10,...
5d859cb
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.