Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
41 lines (27 sloc) 1.07 KB

Rails Legacy Mapper

Build Status Dependency Status

This gem provides an extraction of the DeprecatedMapper from Rails 3.0. If you have a legacy application with an old style routes.rb file this allows you to get your application running quickly in Rails 3.1.

Example

The trigger for using the legacy mapper is the arity (number of args) of the block passed to draw, e.g:

LegacyApp::Application.routes.draw do |map|

  map.root :controller => 'pages', :action => 'index'

  map.namespace :admin do |admin|
    admin.resources :pages
  end

  map.page '/pages/:id', :controller => 'pages', :action => 'show'

  map.connect '/:controller/:action/:id/'

end

License

Copyright (c) 2011 Andrew White, released under the MIT license