Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 46 lines (40 sloc) 1.473 kb
9de111f @pixeltrix Initial release
authored
1 # -*- encoding: utf-8 -*-
2 $:.push File.expand_path("../lib", __FILE__)
3 require "sortifiable/version"
4
5 Gem::Specification.new do |s|
6 s.name = "sortifiable"
7 s.version = Sortifiable::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ["Andrew White"]
10 s.email = ["andyw@pixeltrix.co.uk"]
11 s.homepage = %q{http://github.com/pixeltrix/sortifiable/}
12 s.summary = %q{Sort your models}
13 s.description = <<-EOF
14 This gem provides an acts_as_list compatible capability for sorting
15 and reordering a number of objects in a list. The class that has this
16 specified needs to have a +position+ column defined as an integer on
17 the mapped database table.
18
19 This gem requires ActiveRecord 3.0 as it has been refactored to use
20 the scope methods and query interface introduced with Ruby on Rails 3.0
21 EOF
22
23 s.files = [
24 ".gemtest",
25 "CHANGELOG",
26 "LICENSE",
fdff578 @pixeltrix Add markdown formatted README to gemspec
authored
27 "README.md",
9de111f @pixeltrix Initial release
authored
28 "Rakefile",
29 "lib/sortifiable.rb",
30 "lib/sortifiable/version.rb",
31 "sortifiable.gemspec",
32 "test/sortifiable_test.rb"
33 ]
34
35 s.test_files = ["test/sortifiable_test.rb"]
36 s.require_paths = ["lib"]
37
903038b @pixeltrix Loosen gem dependencies so that it will work with Rails edge
authored
38 s.add_dependency "activesupport", ">= 3.0"
39 s.add_dependency "activerecord", ">= 3.0"
5a5d95f @pixeltrix Test across supported versions of Active Record
authored
40 s.add_development_dependency "appraisal", "~> 0.5"
763db2c @pixeltrix Relax mysql gem dependency
authored
41 s.add_development_dependency "mysql", ">= 2.8.1"
ab6f73c @pixeltrix Loosen dependencies so we can test Rails 3.0 and Rails 3.1
authored
42 s.add_development_dependency "mysql2", ">= 0.2.7"
43 s.add_development_dependency "pg", ">= 0.9.0"
44 s.add_development_dependency "sqlite3", ">= 1.3.3"
9de111f @pixeltrix Initial release
authored
45 end
Something went wrong with that request. Please try again.