Skip to content
Browse files

Prepare for 0.0.5 canonical release.

Add thanks to read me.
install instructions to point at radiustar
update bone options
bump version
update history file
update gem spec
  • Loading branch information...
1 parent 0a52e41 commit 4f4863099fbc0cd1f1c959a8878bc924bbb7a190 @pjdavis committed
Showing with 43 additions and 28 deletions.
  1. +6 −1 History.txt
  2. +12 −1 README.rdoc
  3. +5 −5 Rakefile
  4. +19 −20 radiustar.gemspec
  5. +1 −1 version.txt
View
7 History.txt
@@ -1,7 +1,12 @@
+== 0.0.5 / 2012-02-02
+* Bugfixes(charl, Mark Bryars, jamesotron, dguerri, gderosa, mkocher)
+* You can now use VSAs in packets (jamesotron)
+* Add support for CoA and Disconnect Packets (Mark Bryars)
+
== 0.0.4 / 2010-12/04
* github fork (dguerri)
* bugfixes
-* added multiple dictionary files support
+* added multiple dictionary files support (dguerri)
* added accounting support
== 0.0.3 / 2010-06-30
View
13 README.rdoc
@@ -83,7 +83,18 @@ Ruby Radius Library
== INSTALL:
- gem install dguerri-radiustar
+ gem install radiustar
+
+== Thanks:
+Thanks to everyone who has contributed to this project. Without your help and support, this would not have been possible.
+
+* charl
+* Mark Bryars
+* jamesotron
+* dguerri
+* gderosa
+* mkocher
+* bwlang
== LICENSE:
View
10 Rakefile
@@ -9,12 +9,12 @@ task :default => 'test:run'
task 'gem:release' => 'test:run'
Bones {
- name 'dguerri-radiustar'
- authors 'PJ Davis', 'Davide Guerri'
- email 'davide.guerri@gmail.com'
- url 'http://github.com/dguerri/radiustar'
+ name 'radiustar'
+ authors 'PJ Davis'
+ email 'pj.davis@gmail.com'
+ url 'http://github.com/pjdavis/radiustar'
ignore_file '.gitignore'
readme_file 'README.rdoc'
-
+ depend_on 'ipaddr_extensions'
}
View
39 radiustar.gemspec
@@ -1,37 +1,36 @@
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{radiustar}
- s.version = "0.0.8"
+ s.name = "radiustar"
+ s.version = "0.0.5"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["PJ Davis", "Davide Guerri", "James Harton"]
- s.date = %q{2011-07-11}
- s.description = %q{Ruby Radius Library}
- s.email = %q{jamesotron@gmail.com}
- s.extra_rdoc_files = ["History.txt", "README.rdoc", "templates/default.txt", "version.txt"]
- s.files = [".gitignore", "History.txt", "README.rdoc", "Rakefile", "lib/radiustar.rb", "lib/radiustar/dictionary.rb", "lib/radiustar/dictionary/attributes.rb", "lib/radiustar/dictionary/values.rb", "lib/radiustar/packet.rb", "lib/radiustar/radiustar.rb", "lib/radiustar/request.rb", "lib/radiustar/vendor.rb", "radiustar.gemspec", "spec/radiustar_spec.rb", "spec/spec_helper.rb", "templates/default.txt", "templates/dictionary.digium", "templates/gandalf.dictionary", "test/test_radiustar.rb", "version.txt"]
- s.homepage = %q{http://github.com/dguerri/radiustar}
+ s.authors = ["PJ Davis"]
+ s.date = "2012-02-02"
+ s.description = "Ruby Radius Library"
+ s.email = "pj.davis@gmail.com"
+ s.extra_rdoc_files = ["History.txt", "README.rdoc", "templates/default.txt"]
+ s.files = ["History.txt", "README.rdoc", "Rakefile", "lib/radiustar.rb", "lib/radiustar/dictionary.rb", "lib/radiustar/dictionary/attributes.rb", "lib/radiustar/dictionary/values.rb", "lib/radiustar/packet.rb", "lib/radiustar/radiustar.rb", "lib/radiustar/request.rb", "lib/radiustar/vendor.rb", "radiustar.gemspec", "spec/radiustar_spec.rb", "spec/spec_helper.rb", "spec/value_spec.rb", "templates/default.txt", "templates/dictionary.digium", "templates/dictionary.rfc2865", "templates/gandalf.dictionary", "test/test_radiustar.rb", "version.txt"]
+ s.homepage = "http://github.com/pjdavis/radiustar"
s.rdoc_options = ["--main", "README.rdoc"]
s.require_paths = ["lib"]
- s.rubyforge_project = %q{radiustar}
- s.rubygems_version = %q{1.3.6}
- s.summary = %q{Ruby Radius Library}
+ s.rubyforge_project = "radiustar"
+ s.rubygems_version = "1.8.15"
+ s.summary = "."
s.test_files = ["test/test_radiustar.rb"]
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<bones>, [">= 3.4.1"])
- s.add_development_dependency(%q<ipaddr_extensions>)
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<ipaddr_extensions>, [">= 2012.1.13"])
+ s.add_development_dependency(%q<bones>, [">= 3.7.3"])
else
- s.add_dependency(%q<bones>, [">= 3.4.1"])
- s.add_dependency(%q<ipaddr_extensions>)
+ s.add_dependency(%q<ipaddr_extensions>, [">= 2012.1.13"])
+ s.add_dependency(%q<bones>, [">= 3.7.3"])
end
else
- s.add_dependency(%q<bones>, [">= 3.4.1"])
- s.add_dependency(%q<ipaddr_extensions>)
+ s.add_dependency(%q<ipaddr_extensions>, [">= 2012.1.13"])
+ s.add_dependency(%q<bones>, [">= 3.7.3"])
end
end
View
2 version.txt
@@ -1 +1 @@
-0.0.4
+0.0.5

0 comments on commit 4f48630

Please sign in to comment.
Something went wrong with that request. Please try again.