Skip to content

Loading…

Make headers conform to package.el requirements #1

Merged
merged 1 commit into from

2 participants

@purcell

The source is not currently parseable by package-buffer-info, which renders it uninstallable from a single-file ELPA package. This commit fixes that, and adds an explicit dependency on Emacs >= 24, since lexical-binding is not available in older versions.

Background: I'm adding a MELPA recipe for bufshow. :-)

-Steve

@purcell purcell Make headers conform to package.el requirements
The source is not parseable by `package-buffer-info`, which
renders it uninstallable from a single-file ELPA package. This
commit fixes that, and adds an explicit dependency on Emacs
>= 24, since `lexical-binding` is not available in older versions.
3ee977c
@pjones pjones merged commit 299b512 into pjones:master
@pjones
Owner

Excellent, thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Mar 27, 2013
  1. @purcell

    Make headers conform to package.el requirements

    purcell committed
    The source is not parseable by `package-buffer-info`, which
    renders it uninstallable from a single-file ELPA package. This
    commit fixes that, and adds an explicit dependency on Emacs
    >= 24, since `lexical-binding` is not available in older versions.
Showing with 6 additions and 1 deletion.
  1. +6 −1 lisp/bufshow.el
View
7 lisp/bufshow.el
@@ -1,10 +1,10 @@
-;;; -*- lexical-binding: t -*-
;;; bufshow.el -- A simple presentation tool for Emacs.
;;
;; Copyright (C) 2012 Peter Jones <pjones@pmade.com>
;;
;; Author: Peter Jones <pjones@pmade.com>
;; URL: https://github.com/pjones/bufshow
+;; Package-Requires: ((emacs "24.1"))
;; Version: 0.1.0
;;
;; This file is not part of GNU Emacs.
@@ -39,6 +39,11 @@
;; WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
;;
;;; Code:
+
+;; Local Variables:
+;; lexical-binding: t
+;; End:
+
(eval-when-compile
(require 'org))
Something went wrong with that request. Please try again.