Skip to content
Browse files

Small update to the specs.

  • Loading branch information...
1 parent de8f24e commit 210315e5309fbe138c9efeeca3c8f4a390b56b1d @pk committed Nov 10, 2009
Showing with 6 additions and 2 deletions.
  1. +6 −2 spec/sequel_ext_spec.rb
View
8 spec/sequel_ext_spec.rb
@@ -7,13 +7,17 @@ class SpecModel < Sequel::Model; end
describe "active model" do
it "should load active model plugin when > 3.5" do
- SpecModel.plugins.should include(Sequel::Plugins::ActiveModel)
+ begin
+ SpecModel.plugins.should include(Sequel::Plugins::ActiveModel)
+ rescue NoMethodError
+ pending("For this SPEC to run and pass you need to install Sequel >= 3.5")
+ end
end
it "should include ActiveModelCompatibility module if plugin is not available" do
begin
Sequel::Model.plugin :active_model
- pending("For this SPEC to run and pass we need to install Sequel < 3.5")
+ pending("For this SPEC to run and pass you need to install Sequel < 3.5")
rescue LoadError, NoMethodError
SpecModel.ancestors.should include(Merb::Orms::Sequel::Model::ActiveModelCompatibility)
end

0 comments on commit 210315e

Please sign in to comment.
Something went wrong with that request. Please try again.