Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Dropping support for Sequel < 2.7.0. Due to change in Model.errors wh…

…ich is needed for the merb_helpers.
  • Loading branch information...
commit b04cc91c2cda5ded5c8d00779d2cf84edb879a43 1 parent bb5423a
@pk authored
Showing with 10 additions and 6 deletions.
  1. +4 −0 CHANGELOG
  2. +2 −2 Rakefile
  3. +4 −4 pk-merb_sequel.gemspec
View
4 CHANGELOG
@@ -1,3 +1,7 @@
+== 1.0.8
+
+* Dropped support for Sequel versions < 2.7.0
+
== 1.0.7
* Add support for ActiveModel via active_model plugin for Sequel > 3.5.0 or
View
4 Rakefile
@@ -17,7 +17,7 @@ GEM_EMAIL = "wayneeseguin@gmail.com, lancecarlson@gmail.com, email@loriholden.c
GEM_NAME = "pk-merb_sequel"
PKG_BUILD = ENV['PKG_BUILD'] ? '.' + ENV['PKG_BUILD'] : ''
-GEM_VERSION = "1.0.7" + PKG_BUILD
+GEM_VERSION = "1.0.8" + PKG_BUILD
RELEASE_NAME = "REL #{GEM_VERSION}"
@@ -34,7 +34,7 @@ spec = Gem::Specification.new do |s|
s.email = GEM_EMAIL
s.homepage = PROJECT_URL
s.add_dependency("merb-core", ">= 0.9.9")
- s.add_dependency("sequel", ">= 1.4.0")
+ s.add_dependency("sequel", ">= 2.7.0")
s.files = %w(CHANGELOG LICENSE README.rdoc Rakefile TODO Generators) + Dir.glob("{lib}/**/*")
end
View
8 pk-merb_sequel.gemspec
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.name = %q{pk-merb_sequel}
- s.version = "1.0.7"
+ s.version = "1.0.8"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Wayne E. Seguin, Lance Carlson, Lori Holden, Pavel Kunc"]
@@ -23,13 +23,13 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<merb-core>, [">= 0.9.9"])
- s.add_runtime_dependency(%q<sequel>, [">= 1.4.0"])
+ s.add_runtime_dependency(%q<sequel>, [">= 2.7.0"])
else
s.add_dependency(%q<merb-core>, [">= 0.9.9"])
- s.add_dependency(%q<sequel>, [">= 1.4.0"])
+ s.add_dependency(%q<sequel>, [">= 2.7.0"])
end
else
s.add_dependency(%q<merb-core>, [">= 0.9.9"])
- s.add_dependency(%q<sequel>, [">= 1.4.0"])
+ s.add_dependency(%q<sequel>, [">= 2.7.0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.