Skip to content
Browse files

Modified pyredditstories.py to try to load `json` first (which is in …

…Python 2.6 stdlib), and then fall back to `simplesjon`.

Modified readme.txt to explain that `simplejson` may not be necessary if using Python 2.6.
  • Loading branch information...
1 parent 4bcd2db commit 48850f3fda3e79de914dbf006f0468ca830f4db3 @pkrumins committed
Showing with 10 additions and 2 deletions.
  1. +5 −1 pyredditstories.py
  2. +5 −1 readme.txt
View
6 pyredditstories.py
@@ -16,7 +16,11 @@
import socket
import urllib2
import datetime
-import simplejson as json
+
+try:
+ import json
+except:
+ import simplejson as json
version = "1.0"
View
6 readme.txt
@@ -34,12 +34,16 @@ displays them in the console via ncurses.
The program is written in Python programming language and is supposed to
be run on Unix type operating systems, such as Linux.
-It uses one external Python module:
+If you are using Python older than 2.6, it will require one external Python
+module:
* simplejson - for parsing the reddit stories.
It can be installed via `easy_install simplejson` command or can be
downloaded from http://undefined.org/python/#simplejson
+Python 2.6 has json in the standard library, so it should work out of the box.
+
+
See my original article for a screenshot:
http://www.catonmat.net/blog/follow-reddit-from-the-console/

0 comments on commit 48850f3

Please sign in to comment.
Something went wrong with that request. Please try again.