Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Checking in changes prior to tagging of version 0.9971.

Changelog diff is:

diff --git a/Changes b/Changes
index 4ccf4fc..e50439a 100644
--- a/Changes
+++ b/Changes
@@ -2,6 +2,12 @@ Revision history for Perl extension Plack

 Take a look at http://github.com/miyagawa/Plack/issues for the planned changes before 1.0 release.

+0.9971  Wed Feb 23 14:02:35 PST 2011
+    [INCOMPATIBLE CHANGES]
+        - Localize $0 to the given .psgi path when evaluating it in Plack::Util::load_psgi()
+          This fixes the unexpected values and/or crashes with Starman when your application
+          uses FindBin module.
+
 0.9970  Tue Feb 22 08:35:50 PST 2011
         - Apache2: Fixed a bug where dispatcher fails to parse first path when it begins with two or
           more slashes (clkao)
  • Loading branch information...
commit 3b0b41bc61d9faf395e2b00312a45d6f4ec09fbb 1 parent 3da9baf
@miyagawa miyagawa authored
View
6 Changes
@@ -2,6 +2,12 @@ Revision history for Perl extension Plack
Take a look at http://github.com/miyagawa/Plack/issues for the planned changes before 1.0 release.
+0.9971 Wed Feb 23 14:02:35 PST 2011
+ [INCOMPATIBLE CHANGES]
+ - Localize $0 to the given .psgi path when evaluating it in Plack::Util::load_psgi()
+ This fixes the unexpected values and/or crashes with Starman when your application
+ uses FindBin module.
+
0.9970 Tue Feb 22 08:35:50 PST 2011
- Apache2: Fixed a bug where dispatcher fails to parse first path when it begins with two or
more slashes (clkao)
View
1  MANIFEST
@@ -260,6 +260,7 @@ t/Plack-Test/hello_server.t
t/Plack-Test/suite.t
t/Plack-Util/bad.psgi
t/Plack-Util/bad2.psgi
+t/Plack-Util/bin/findbin.psgi
t/Plack-Util/error.psgi
t/Plack-Util/foreach.t
t/Plack-Util/headers.t
View
2  lib/Plack.pm
@@ -3,7 +3,7 @@ package Plack;
use strict;
use warnings;
use 5.008_001;
-our $VERSION = '0.9970';
+our $VERSION = '0.9971';
$VERSION = eval $VERSION;
1;
View
2  lib/Plack/Request.pm
@@ -2,7 +2,7 @@ package Plack::Request;
use strict;
use warnings;
use 5.008_001;
-our $VERSION = '0.9970';
+our $VERSION = '0.9971';
$VERSION = eval $VERSION;
use HTTP::Headers;
View
2  lib/Plack/Response.pm
@@ -1,7 +1,7 @@
package Plack::Response;
use strict;
use warnings;
-our $VERSION = '0.9970';
+our $VERSION = '0.9971';
$VERSION = eval $VERSION;
use Plack::Util::Accessor qw(body status);
View
2  lib/Plack/Server/ServerSimple.pm
@@ -1,6 +1,6 @@
package Plack::Server::ServerSimple;
use strict;
-our $VERSION = '0.9970';
+our $VERSION = '0.9971';
$VERSION = eval $VERSION;
use parent qw(Plack::Handler::HTTP::Server::Simple);
Please sign in to comment.
Something went wrong with that request. Please try again.