Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Checking in changes prior to tagging of version 1.0018.

Changelog diff is:

diff --git a/Changes b/Changes
index db54eea..26bb00c 100644
--- a/Changes
+++ b/Changes
@@ -1,6 +1,16 @@
 Go to http://github.com/plack/Plack/issues for the roadmap and known issues.

-1.0017 Thu Feb  7 19:21:24 PST 2013
+1.0018 Fri Mar  8 10:43:45 PST 2013
+    [IMPROVEMENTS]
+        - Performance boost in Plack::Request#query_parameters (lestrrat)
+        - Added custom log formats for %m, %U, %q and %H (Hiroshi Sakai)
+        - Fixed warnings in SimpleContentFilter (earino)
+
+    [DOCUMENTATION]
+        - Added docs about plackup --path
+        - Added docs about using manager object in Plack::Handler::FCGI
+
+1.0017-TRIAL Thu Feb  7 19:21:24 PST 2013
     [INCOMPATIBLE CHANGES]
         - Gives you warnings when you use one of Plack::App objects in `plackup -e` or
           in .psgi files but forgot to call ->to_app to make it a PSGI application (#369)
  • Loading branch information...
commit 3fb5c9a1943668f18924dc35d3988b9c039727ec 1 parent 5413ff1
@miyagawa miyagawa authored
View
12 Changes
@@ -1,6 +1,16 @@
Go to http://github.com/plack/Plack/issues for the roadmap and known issues.
-1.0017 Thu Feb 7 19:21:24 PST 2013
+1.0018 Fri Mar 8 10:43:45 PST 2013
+ [IMPROVEMENTS]
+ - Performance boost in Plack::Request#query_parameters (lestrrat)
+ - Added custom log formats for %m, %U, %q and %H (Hiroshi Sakai)
+ - Fixed warnings in SimpleContentFilter (earino)
+
+ [DOCUMENTATION]
+ - Added docs about plackup --path
+ - Added docs about using manager object in Plack::Handler::FCGI
+
+1.0017-TRIAL Thu Feb 7 19:21:24 PST 2013
[INCOMPATIBLE CHANGES]
- Gives you warnings when you use one of Plack::App objects in `plackup -e` or
in .psgi files but forgot to call ->to_app to make it a PSGI application (#369)
View
2  lib/Plack.pm
@@ -3,7 +3,7 @@ package Plack;
use strict;
use warnings;
use 5.008_001;
-our $VERSION = '1.0017';
+our $VERSION = '1.0018';
$VERSION = eval $VERSION;
1;
View
2  lib/Plack/Request.pm
@@ -2,7 +2,7 @@ package Plack::Request;
use strict;
use warnings;
use 5.008_001;
-our $VERSION = '1.0017';
+our $VERSION = '1.0018';
$VERSION = eval $VERSION;
use HTTP::Headers;
View
2  lib/Plack/Response.pm
@@ -1,7 +1,7 @@
package Plack::Response;
use strict;
use warnings;
-our $VERSION = '1.0017';
+our $VERSION = '1.0018';
$VERSION = eval $VERSION;
use Plack::Util::Accessor qw(body status);
Please sign in to comment.
Something went wrong with that request. Please try again.