Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Checking in changes prior to tagging of version 0.9979.

Changelog diff is:

diff --git a/Changes b/Changes
index 97a9d3b..ce2ef5d 100644
--- a/Changes
+++ b/Changes
@@ -2,6 +2,18 @@ Revision history for Perl extension Plack

 Take a look at http://github.com/miyagawa/Plack/issues for the planned changes before 1.0 release.

+0.9979  Tue May 17 09:54:03 PDT 2011
+    [BUG FIXES]
+        - Fixed Middleware::AccessLog's default %t format to match Apache's format
+        - Fixed a warning in Apache1 handler where PATH_INFO doesn't exist #204
+        - Fixed a bad test relying on new Test::More versions
+
+    [IMPROVEMENTS]
+        - Fixed Lint to accept bare in-memory filehandle per http://stackoverflow.com/questions/6011793/
+        - Added setup_env() to Plack::Handler::CGI (markstos)
+        - Added a non-blocking Hello World example in eg/dot-psgi
+        - Doc cleanup
+
 0.9978  Wed May  4 11:29:12 PDT 2011
     [TEST FIXES]
         - Fixed a failing output_encoding.t because of FCGI dependencies
  • Loading branch information...
commit 60fb5c448db1f381eb499a53249394d3180b98a6 1 parent d90d132
@miyagawa miyagawa authored
View
12 Changes
@@ -2,6 +2,18 @@ Revision history for Perl extension Plack
Take a look at http://github.com/miyagawa/Plack/issues for the planned changes before 1.0 release.
+0.9979 Tue May 17 09:54:03 PDT 2011
+ [BUG FIXES]
+ - Fixed Middleware::AccessLog's default %t format to match Apache's format
+ - Fixed a warning in Apache1 handler where PATH_INFO doesn't exist #204
+ - Fixed a bad test relying on new Test::More versions
+
+ [IMPROVEMENTS]
+ - Fixed Lint to accept bare in-memory filehandle per http://stackoverflow.com/questions/6011793/
+ - Added setup_env() to Plack::Handler::CGI (markstos)
+ - Added a non-blocking Hello World example in eg/dot-psgi
+ - Doc cleanup
+
0.9978 Wed May 4 11:29:12 PDT 2011
[TEST FIXES]
- Fixed a failing output_encoding.t because of FCGI dependencies
View
1  MANIFEST
@@ -20,6 +20,7 @@ eg/dot-psgi/frameworks/Schenker.psgi
eg/dot-psgi/frameworks/Squatting.psgi
eg/dot-psgi/Hello.psgi
eg/dot-psgi/image.psgi
+eg/dot-psgi/nonblock-hello.psgi
eg/dot-psgi/plack-req.psgi
eg/dot-psgi/runnable.psgi
eg/dot-psgi/slowapp.psgi
View
1  MANIFEST.SKIP
@@ -19,3 +19,4 @@
^\.shipit$
\.git
nytprof/
+MYMETA
View
2  lib/Plack.pm
@@ -3,7 +3,7 @@ package Plack;
use strict;
use warnings;
use 5.008_001;
-our $VERSION = '0.9978';
+our $VERSION = '0.9979';
$VERSION = eval $VERSION;
1;
View
2  lib/Plack/Request.pm
@@ -2,7 +2,7 @@ package Plack::Request;
use strict;
use warnings;
use 5.008_001;
-our $VERSION = '0.9978';
+our $VERSION = '0.9979';
$VERSION = eval $VERSION;
use HTTP::Headers;
View
2  lib/Plack/Response.pm
@@ -1,7 +1,7 @@
package Plack::Response;
use strict;
use warnings;
-our $VERSION = '0.9978';
+our $VERSION = '0.9979';
$VERSION = eval $VERSION;
use Plack::Util::Accessor qw(body status);
View
2  lib/Plack/Server/ServerSimple.pm
@@ -1,6 +1,6 @@
package Plack::Server::ServerSimple;
use strict;
-our $VERSION = '0.9978';
+our $VERSION = '0.9979';
$VERSION = eval $VERSION;
use parent qw(Plack::Handler::HTTP::Server::Simple);
Please sign in to comment.
Something went wrong with that request. Please try again.