Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Checking in changes prior to tagging of version 1.0017.

Changelog diff is:

diff --git a/Changes b/Changes
index 084f1fd..db54eea 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,15 @@
 Go to http://github.com/plack/Plack/issues for the roadmap and known issues.

+1.0017 Thu Feb  7 19:21:24 PST 2013
+    [INCOMPATIBLE CHANGES]
+        - Gives you warnings when you use one of Plack::App objects in `plackup -e` or
+          in .psgi files but forgot to call ->to_app to make it a PSGI application (#369)
+          Still automatically converts them for backward compatibility, but in the
+          loading time inside Plack::Builder.
+
+    [BUG FIXES]
+        - chdir to the CGI path when executing CGIBin (#338, #368)
+
 1.0016 Thu Jan 31 13:21:14 PST 2013
     [SECURITY]
         - Fixed directory traversal bug in Plack::App::File on win32 environments
  • Loading branch information...
commit d81ca205dc703a19802b1d6a7f4e7a1c571c0380 1 parent 8ba7fcb
@miyagawa miyagawa authored
View
10 Changes
@@ -1,5 +1,15 @@
Go to http://github.com/plack/Plack/issues for the roadmap and known issues.
+1.0017 Thu Feb 7 19:21:24 PST 2013
+ [INCOMPATIBLE CHANGES]
+ - Gives you warnings when you use one of Plack::App objects in `plackup -e` or
+ in .psgi files but forgot to call ->to_app to make it a PSGI application (#369)
+ Still automatically converts them for backward compatibility, but in the
+ loading time inside Plack::Builder.
+
+ [BUG FIXES]
+ - chdir to the CGI path when executing CGIBin (#338, #368)
+
1.0016 Thu Jan 31 13:21:14 PST 2013
[SECURITY]
- Fixed directory traversal bug in Plack::App::File on win32 environments
View
1  MANIFEST
@@ -149,6 +149,7 @@ t/Plack-Middleware/auth_basic_simple.t
t/Plack-Middleware/bufferedstreaming.t
t/Plack-Middleware/cascade/basic.t
t/Plack-Middleware/cascade/streaming.t
+t/Plack-Middleware/cgi-bin/cgi_dir.cgi
t/Plack-Middleware/cgi-bin/hello.cgi
t/Plack-Middleware/cgi-bin/hello.py
t/Plack-Middleware/cgi-bin/hello2.cgi
View
2  lib/Plack.pm
@@ -3,7 +3,7 @@ package Plack;
use strict;
use warnings;
use 5.008_001;
-our $VERSION = '1.0016';
+our $VERSION = '1.0017';
$VERSION = eval $VERSION;
1;
View
2  lib/Plack/Request.pm
@@ -2,7 +2,7 @@ package Plack::Request;
use strict;
use warnings;
use 5.008_001;
-our $VERSION = '1.0016';
+our $VERSION = '1.0017';
$VERSION = eval $VERSION;
use HTTP::Headers;
View
2  lib/Plack/Response.pm
@@ -1,7 +1,7 @@
package Plack::Response;
use strict;
use warnings;
-our $VERSION = '1.0016';
+our $VERSION = '1.0017';
$VERSION = eval $VERSION;
use Plack::Util::Accessor qw(body status);
Please sign in to comment.
Something went wrong with that request. Please try again.