Permalink
Browse files

wing.vue.js now requires <script src="https://cdn.jsdelivr.net/npm/qs…

  • Loading branch information...
rizen committed Jun 25, 2018
1 parent a04ec78 commit c22afa0bf0a5fa687c4b4a171049d2b9f5d626c9
Showing with 5 additions and 0 deletions.
  1. +1 −0 CHANGES.txt
  2. +3 −0 public/wing.vue.js
  3. +1 −0 var/init/views/wing_ui_js_requirements.tt
View
@@ -9,6 +9,7 @@ with respect to new features and compatibility changes.
* Added an error message if you don't pass in a api url for wing.vue.js delete().
* Fixed a bug in error handling in wing.vue.js delete.
* Added wing.base_uri property to wing.vue.js.
* wing.vue.js now requires <script src="https://cdn.jsdelivr.net/npm/qs@6.5.2/dist/qs.js"></script>.
2018-06-22
* libpng should be compiled with Wing because the RPMs found in many places don't contain pngfix.
View
@@ -10,6 +10,9 @@ axios.defaults.headers.get['If-Modified-Since'] = 'Mon, 26 Jul 1997 05:00:00 GMT
//more cache control
axios.defaults.headers.get['Cache-Control'] = 'no-cache';
axios.defaults.headers.get['Pragma'] = 'no-cache';
axios.defaults.paramsSerializer = function(params) {
return Qs.stringify(params, {arrayFormat: 'repeat'});
};
axios.interceptors.request.use(function (config) {
wing.throbber.working();
return config;
@@ -4,5 +4,6 @@
<script src="https://cdn.jsdelivr.net/npm/vue2-filters@0.3.0/dist/vue2-filters.min.js"></script>
<script src="https://cdn.jsdelivr.net/npm/noty@3.2.0-beta/lib/noty.min.js"></script>
<script src="https://cdn.jsdelivr.net/npm/lodash@4.17.5/lodash.min.js"></script>
<script src="https://cdn.jsdelivr.net/npm/qs@6.5.2/dist/qs.js"></script>
<script src="https://unpkg.com/axios@0.18.0/dist/axios.min.js"></script>
<script src="/wing.vue.js?v=gjhih"></script>

0 comments on commit c22afa0

Please sign in to comment.