Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Data from the database is not completely displayed on the page. #1260

Open
SemperEtAnte opened this issue Dec 21, 2019 · 6 comments
Open

Data from the database is not completely displayed on the page. #1260

SemperEtAnte opened this issue Dec 21, 2019 · 6 comments

Comments

@SemperEtAnte
Copy link

@SemperEtAnte SemperEtAnte commented Dec 21, 2019

I am outputting information through the API to the statistics page. Just a few separate plugins, each of which has 3 tabs with a table, in the style of "Current time", "Previous month", "All time". At the same time, normal data is entered into the plugin database, but not all of them are shown on the page in tables. Queris in my plugin are 100% correct

@Rsl1122

This comment has been minimized.

Copy link
Collaborator

@Rsl1122 Rsl1122 commented Dec 21, 2019

Is this about Data Extension API?

If so please double check the sections about how the data in Plan is updated (two sections in this part of the documentation) https://github.com/plan-player-analytics/Plan/wiki/APIv5---DataExtension-API#-provider-annotations

@SemperEtAnte

This comment has been minimized.

Copy link
Author

@SemperEtAnte SemperEtAnte commented Dec 21, 2019

Is this about Data Extension API?

If so please double check the sections about how the data in Plan is updated (two sections in this part of the documentation) https://github.com/plan-player-analytics/Plan/wiki/APIv5---DataExtension-API#-provider-annotations

Yes. About Data Extension API.
All correct. The plugin database contains correct data, but not all of data are displayed on pages

@Rsl1122

This comment has been minimized.

Copy link
Collaborator

@Rsl1122 Rsl1122 commented Dec 21, 2019

Ok so Plan database contains the proper data but the queries in Plan are not displaying the data?

Could you screenshot some example data and the faulty output in order to start figuring out the part the problem is in?

@SemperEtAnte

This comment has been minimized.

Copy link
Author

@SemperEtAnte SemperEtAnte commented Dec 21, 2019

@Rsl1122

This comment has been minimized.

Copy link
Collaborator

@Rsl1122 Rsl1122 commented Dec 21, 2019

Alright. Seems like a bug indeed.

@Rsl1122 Rsl1122 added Bug and removed Investigating 🕵️ labels Dec 21, 2019
@Rsl1122 Rsl1122 added this to Backlog (HIGH Priority) in Active Development Jan 6, 2020
Rsl1122 added a commit that referenced this issue Jan 13, 2020
Original query used an odd inner join which caused some tables to
not be displayed at all, in some cases no tables were displayed at all.
The inner join was joining the value table, which is lower in the table hierarchy.

Changed the query to instead inner join upwards in the table hierarchy, joining the
plugin table.

Affects issues:
- #1260
Rsl1122 added a commit that referenced this issue Jan 17, 2020
Original query used an odd inner join which caused some tables to
not be displayed at all, in some cases no tables were displayed at all.
The inner join was joining the value table, which is lower in the table hierarchy.

Changed the query to instead inner join upwards in the table hierarchy, joining the
plugin table.

Affects issues:
- #1260
@Rsl1122

This comment has been minimized.

Copy link
Collaborator

@Rsl1122 Rsl1122 commented Jan 29, 2020

Has the situation improved with newer versions?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
Active Development
  
Backlog (HIGH Priority)
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.