Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Server crash #1326

Open
mcqwy opened this issue Feb 9, 2020 · 3 comments
Open

Server crash #1326

mcqwy opened this issue Feb 9, 2020 · 3 comments

Comments

@mcqwy
Copy link

@mcqwy mcqwy commented Feb 9, 2020

This is the breakdown question I asked at sponge.
I like your plug-in very much
Unfortunately, it may have problems
But I didn't see its error in the log
url
You may not believe it
Yes, I didn't believe it at first
However, after I removed plan-5.0-build-382.jar, the effect was obviously improved.
On February 8, there was a constant breakdown
It's all because the timeout is 60s
On February 9, after I uninstalled, there was no crash
If the crash doesn't happen again on February 10, it's definitely plan's problem
I'll keep testing tomorrow.
Plan Version: plan-5.0-build-382

@Rsl1122

This comment has been minimized.

Copy link
Collaborator

@Rsl1122 Rsl1122 commented Feb 9, 2020

Try accepting GeoLite2 EULA - see 'Data_gathering.Accept_GeoLite2_EULA' in the config.

[10:10:52] [pool-3-thread-3/WARN] [plan]: Fallback: using IP2C for Geolocation (doesn't support IPv6).

IP2C has been causing issues on SpongeForge in previous versions - perhaps it is still the issue

@mcqwy

This comment has been minimized.

Copy link
Author

@mcqwy mcqwy commented Feb 9, 2020

Now the service provider is maintaining, I will continue to test tomorrow
Please wait for the good news tomorrow
I can configure IP6 support
But my country has not popularized the use of IP6
Can this solve the problem?

@Rsl1122

This comment has been minimized.

Copy link
Collaborator

@Rsl1122 Rsl1122 commented Feb 14, 2020

How did it go?

Previously the crashes have not been caused by the fact that IP2C doesn't support IPv6, but the fact that it uses HTTP to call an API.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.