Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Special characters & and ~ not handled in latex output #81

Closed
BlueAndi opened this Issue Nov 5, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@BlueAndi
Copy link

BlueAndi commented Nov 5, 2017

Using PlantUML version 1.2017.18 (Fri Oct 06 18:56:32 CEST 2017) to generate UML class diagrams in latex.

Example UML diagram:
@startuml
class A {
+ A()
+ ~A()
+ A(in a : const A&)
}
@enduml

The ~ should be converted to \~{}, the & should be converted to \& to be handled correct in latex.

@arnaudroques

This comment has been minimized.

Copy link
Contributor

arnaudroques commented Nov 5, 2017

Thanks for the report!
The ~ issue should be fixed in last beta (beta17)
http://beta.plantuml.net/plantuml.jar

About & it seems that \& is needed for us.
See https://www.overleaf.com/read/myvpxjrpcndr
Any thought ?

@BlueAndi

This comment has been minimized.

Copy link
Author

BlueAndi commented Nov 5, 2017

I checked it with the PlantUML version 1.2017.19beta17 and both is looking good for me.

Regarding the & in my previous comment, the backslash was not shown, because I forgot to mark them as code. :-)

Perfect! Thanks.

@BlueAndi BlueAndi closed this Nov 5, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.