Skip to content
Permalink
Browse files

Don't run `gem update --system` and `gem install bundler` on CI

There were some issues with the combination of some `bundler` and `rubygems` versions.
We got around that by always updating `bundler` in the CI but since those issues
were fixed we can quit doing that.

Related to `gem update --system`:
- travis-ci/travis-ci#8978
- rubygems/rubygems#2123

Related to `gem install bundler`:
- travis-ci/travis-ci#9333
- travis-ci/travis-ci#8969
- bundler/bundler#6340
  • Loading branch information...
mracos committed Dec 19, 2018
1 parent bf74a50 commit 6e4b0b94bcec39c7dfdcc89e1f5768ab3e71defb
Showing with 1 addition and 4 deletions.
  1. +1 −4 .travis.yml
@@ -51,10 +51,7 @@ env:
- DEVISE_ORM=active_record
- DEVISE_ORM=mongoid

before_install:
- gem update --system
- gem install bundler
- "rm ${BUNDLE_GEMFILE}.lock"
before_install: "rm ${BUNDLE_GEMFILE}.lock"

before_script: "bundle update"

0 comments on commit 6e4b0b9

Please sign in to comment.
You can’t perform that action at this time.