Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Error with user sign-up and confirmation confirm bug like issue 193 #219

Closed
mcdba opened this Issue Apr 20, 2010 · 3 comments

Comments

Projects
None yet
2 participants

mcdba commented Apr 20, 2010

Confirm this bug

Ruby: 1.8.7 (p249)
Rails: 2.3.5
Devise (gem): 1.0.6

devise :registerable, :database_authenticatable, :confirmable, ....

When user sign_up correct email with confirmation url send to email,
but ueser without confirmation is logged !

when user log_out its may login again without any confirmation steps via emai

Also confirm bug with word TRUE in output before flash on root page ( after sucsessfuly sign_up with confirmable set on)
see html output

true
<< this is BUG
You have signed up successfully.

Comment
Confirm this bug Ruby: 1.8.7 (p249) Rails: 2.3.5 Devise (gem): 1.0.6 devise :registerable, :database_authenticatable, :confirmable, .... When user sign_up correct email with confirmation url send to email, but ueser without confirmation is logged ! when user log_out its may login again without any confirmation steps via emai Also confirm bug with word TRUE in output before flash on root page ( after sucsessfuly sign_up with confirmable set on) see html output

true
<< this is BUG
You have signed up successfully.

or cancel

Owner

josevalim commented Apr 20, 2010

Can you please reproduce the fact you can sign_in without confirmation in a smaller application? How is your config/initializers/devise.rb? A please send me the whole devise declaration in the model.

About the true, I replied in the other ticket and it was fixed in latest versions. But bear in mind that flash can be used not only for messages, but to carry flags as well. So it's a good practice to only show flash messages if they are strings.

mcdba commented Apr 20, 2010

This is only my configuration bug

config.confirm_within = 2.days in initializer devise.rb !

Pls. close issue

Owner

josevalim commented Apr 20, 2010

Exactly. This is what I wanted to know.

It's not a bug, but a feature. The initializer is pretty clear that it gives users access to your application.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment