Permalink
Browse files

Merge pull request #31 from kreeger/master

Updating ActiveSupport patching to use #on_load; moved gem dependencies to gemspec.
  • Loading branch information...
2 parents 23958b4 + b85e5c1 commit 15d0679ccc56f585f90c9954617f0a57053ba535 @josevalim josevalim committed Nov 24, 2012
Showing with 13 additions and 13 deletions.
  1. +0 −11 Gemfile
  2. +12 −1 has_scope.gemspec
  3. +1 −1 lib/has_scope.rb
View
11 Gemfile
@@ -1,14 +1,3 @@
source :rubygems
gemspec
-
-gem "actionpack", "~> 3.2.0"
-gem "activesupport", "~> 3.2.0"
-
-if RUBY_VERSION < "1.9"
- gem "ruby-debug"
-else
- gem "test-unit"
-end
-
-gem "mocha"
View
@@ -24,4 +24,15 @@ Gem::Specification.new do |s|
s.extra_rdoc_files = [
"README.md"
]
-end
+
+ s.add_runtime_dependency "actionpack", "~> 3.2.0"
+ s.add_runtime_dependency "activesupport", "~> 3.2.0"
+ s.add_development_dependency "mocha", "~> 0.12.0"
+ s.add_development_dependency "rake"
+ if RUBY_VERSION < "1.9"
+ s.add_development_dependency "rdoc"
+ s.add_development_dependency "ruby-debug"
+ else
+ s.add_development_dependency "test-unit"
+ end
+end
View
@@ -181,7 +181,7 @@ def current_scopes
end
end
-ActionController::Base.instance_eval do
+ActiveSupport.on_load :action_controller do
include HasScope
helper_method :current_scopes
end

0 comments on commit 15d0679

Please sign in to comment.