Permalink
Browse files

Merge pull request #36 from spectator/rails4

Rails 4 support
  • Loading branch information...
2 parents 15d0679 + 08b092f commit 4a672083e7053d6a24364253fd34ac3a69dc6151 @rafaelfranca rafaelfranca committed Mar 1, 2013
Showing with 30 additions and 13 deletions.
  1. +1 −1 .gitignore
  2. +12 −0 .travis.yml
  3. +5 −0 Gemfile
  4. +8 −0 gemfiles/Gemfile-rails.3.2.x
  5. +2 −10 has_scope.gemspec
  6. +2 −2 test/test_helper.rb
View
@@ -1,2 +1,2 @@
.bundle
-Gemfile.lock
+*.lock
View
@@ -0,0 +1,12 @@
+language: ruby
+rvm:
+ - 1.8.7
+ - 1.9.3
+ - 2.0.0
+gemfile:
+ - Gemfile
+ - gemfiles/Gemfile-rails.3.2.x
+matrix:
+ exclude:
+ - rvm: 1.8.7
+ gemfile: gemfiles/Gemfile.rails-3.2.x
View
@@ -1,3 +1,8 @@
source :rubygems
gemspec
+
+gem 'actionpack', '~> 4.0.0.beta1'
+gem 'activesupport', '~> 4.0.0.beta1'
+gem 'mocha', '~> 0.13.2'
+gem 'rake'
@@ -0,0 +1,8 @@
+source 'https://rubygems.org'
+
+gem 'has_scope', :path => '..'
+
+gem 'actionpack', '~> 3.2.0'
+gem 'activesupport', '~> 3.2.0'
+gem 'mocha', '~> 0.13.2'
+gem 'rake'
View
@@ -25,14 +25,6 @@ Gem::Specification.new do |s|
"README.md"
]
- s.add_runtime_dependency "actionpack", "~> 3.2.0"
- s.add_runtime_dependency "activesupport", "~> 3.2.0"
- s.add_development_dependency "mocha", "~> 0.12.0"
- s.add_development_dependency "rake"
- if RUBY_VERSION < "1.9"
- s.add_development_dependency "rdoc"
- s.add_development_dependency "ruby-debug"
- else
- s.add_development_dependency "test-unit"
- end
+ s.add_runtime_dependency "actionpack", ">= 3.2.0"
+ s.add_runtime_dependency "activesupport", ">= 3.2.0"
end
View
@@ -3,7 +3,7 @@
Bundler.setup
require 'test/unit'
-require 'mocha'
+require 'mocha/setup'
# Configure Rails
ENV["RAILS_ENV"] = "test"
@@ -17,7 +17,7 @@
HasScope::Routes = ActionDispatch::Routing::RouteSet.new
HasScope::Routes.draw do
- match '/:controller(/:action(/:id))'
+ get '/:controller(/:action(/:id))'
end
class ApplicationController < ActionController::Base

0 comments on commit 4a67208

Please sign in to comment.