Permalink
Browse files

Drop support for Rails 3.1 and Ruby 1.8

  • Loading branch information...
1 parent dcf9320 commit a1fd340f3f32739c7091c5d92140685cbc26699e @carlosantoniodasilva carlosantoniodasilva committed May 8, 2013
Showing with 3 additions and 19 deletions.
  1. +0 −12 .travis.yml
  2. +1 −0 CHANGELOG.md
  3. +1 −1 Gemfile.lock
  4. +0 −5 gemfiles/Gemfile-rails.3.1.x
  5. +1 −1 responders.gemspec
View
@@ -1,24 +1,12 @@
language: ruby
rvm:
- - 1.8.7
- - jruby-18mode
- jruby-19mode
- - rbx-18mode
- rbx-19mode
- 1.9.3
- 2.0.0
gemfile:
- - gemfiles/Gemfile-rails.3.1.x
- gemfiles/Gemfile-rails.3.2.x
- Gemfile
-matrix:
- exclude:
- - rvm: 1.8.7
- gemfile: Gemfile
- - rvm: jruby-18mode
- gemfile: Gemfile
- - rvm: rbx-18mode
- gemfile: Gemfile
notifications:
email: false
campfire:
View
@@ -1,5 +1,6 @@
## Unreleased
+* Drop support for Rails 3.1 and Ruby 1.8, keep support for Rails 3.2
* Support for Rails 4.0 onward
* Fix flash message on destroy failure. Fixes #61
View
@@ -2,7 +2,7 @@ PATH
remote: .
specs:
responders (0.9.3)
- railties (>= 3.1)
+ railties (>= 3.2, < 5)
GEM
remote: https://rubygems.org/
@@ -1,5 +0,0 @@
-source 'https://rubygems.org'
-
-gem 'responders', :path => '..'
-gem 'railties', '~> 3.1.0'
-gem 'mocha'
View
@@ -19,5 +19,5 @@ Gem::Specification.new do |s|
s.test_files = Dir["test/**/*"]
s.require_paths = ["lib"]
- s.add_dependency "railties", ">= 3.1"
+ s.add_dependency "railties", ">= 3.2", "< 5"
end

0 comments on commit a1fd340

Please sign in to comment.