Permalink
Browse files

Transition to Rails 4 and Ruby 2.0.

Assuming there is no Rails 3.1 and 3.2 support for these changes.
  • Loading branch information...
1 parent 04789d0 commit f456f857191b439c33b1eb62fe88fbc6b8aafce6 @spectator spectator committed Feb 28, 2013
Showing with 14 additions and 19 deletions.
  1. +1 −3 .travis.yml
  2. +4 −0 CHANGELOG.md
  3. +6 −7 Gemfile
  4. +0 −6 gemfiles/Gemfile-rails.3.1.x
  5. +3 −3 responders.gemspec
View
4 .travis.yml
@@ -3,9 +3,7 @@ rvm:
- 1.9.3
- ree
- jruby-18mode
-gemfile:
- - gemfiles/Gemfile-rails.3.1.x
- - Gemfile
+ - 2.0.0
notifications:
recipients:
- jose.valim@plataformatec.com.br
4 CHANGELOG.md
@@ -1,3 +1,7 @@
+## Unreleased
+
+* Support for Rails 4.0 onward, please use 0.9.3 version for Rails 3
+
## 0.9.3
* Fix url generation for namespaced models
View
13 Gemfile
@@ -1,10 +1,9 @@
-source :rubygems
+source 'https://rubygems.org'
gemspec
-# Fixed 3.2.1 because 3.2.2 is broken
-gem 'railties', '~> 3.2.3'
-
-gem 'mocha'
-
-gem 'ruby-debug', :platform => :mri_18
+group :test do
+ gem 'mocha'
+ gem 'activemodel', '~> 4.0.0.beta1'
+ gem 'ruby-debug', :platform => :mri_18
+end
View
6 gemfiles/Gemfile-rails.3.1.x
@@ -1,6 +0,0 @@
-source :rubygems
-
-gem 'responders', :path => '..'
-
-gem 'railties', '~> 3.1.0'
-gem 'mocha'
View
6 responders.gemspec
@@ -6,10 +6,10 @@ Gem::Specification.new do |s|
s.name = "responders"
s.version = Responders::VERSION.dup
s.platform = Gem::Platform::RUBY
- s.summary = "A set of Rails 3 responders to dry up your application"
+ s.summary = "A set of Rails 4 responders to dry up your application"
s.email = "contact@plataformatec.com.br"
s.homepage = "http://github.com/plataformatec/responders"
- s.description = "A set of Rails 3 responders to dry up your application"
+ s.description = "A set of Rails 4 responders to dry up your application"
s.authors = ['José Valim']
s.rubyforge_project = "responders"
@@ -18,5 +18,5 @@ Gem::Specification.new do |s|
s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
s.require_paths = ["lib"]
- s.add_dependency "railties", "~> 3.1"
+ s.add_dependency "railties", "~> 4.0.0.beta1"
end

0 comments on commit f456f85

Please sign in to comment.