Skip to content
Bringing Rails 3 Responders to your obsolete Rails 2.3.x apps
Ruby
Find file
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
lib
test
.gitignore
CHANGELOG
MIT-LICENSE
README.rdoc
Rakefile
init.rb
responders_backport.gemspec

README.rdoc

Responders Backport for Rails 2.3.x

Loving Rails 3 Responders[1] feature? Me too.

Wants to use Responders in your Rails 2.3.x apps? Use InheritedResources. IR backports [2] Responder to your Rails 2.3.x apps and adds lots of useful and awesome features.

However, in some cases we don't want to use all IR awesome features. So, I extracted Responders-backporting-stuff to a minimal lib. This is mainly to be use as a dependency by Restfulie (github.com/caelum/restfulie)

Notes

1

Please see these posts about Responders :

blog.plataformatec.com.br/2009/12/one-in-three-inherited-resources-has-scope-and-responders/

blog.plataformatec.com.br/2009/08/inherited-resources-is-scopes-and-responder-fluent/

2

This is not entirely true, since Rails 3 Responders was actually inspired by InheritedResources new features to Rails 2.

Copyright © 2010 George Guimarães and José Valim blog.plataformatec.com.br See the attached MIT License.

Something went wrong with that request. Please try again.