:label => false problem #11

Closed
JFCreamer opened this Issue Oct 8, 2010 · 10 comments

Comments

Projects
None yet
4 participants

Not sure what I'm doing wrong, but when I set :label => false to remove the label, I get back a page with the br /, ul class="collection", li, etc. tags as text on the web page. Any thoughts on how to address this?

Collaborator

carlosantoniodasilva commented Oct 8, 2010

Which version are you using? And which Rails version?

Rails 3 and show_for 0.2.3

Collaborator

carlosantoniodasilva commented Oct 8, 2010

Could you please try using the master branch to check if it's ok?
There is already a fix: a9495c7
Let me know if it's ok and I'll manage to release a new version.

I reloaded everything from the master branch, but I still get the same result. Don't know if this makes a difference, but the version was still 0.2.3.

Collaborator

carlosantoniodasilva commented Oct 8, 2010

Weird, did you bundle from :git? I can't take a look at this right now, but you can go ahead, take a look and provide a patch ok.

I get that a lot.)) I did bundle from git. I'll see if I can find a solution or wait until someone better than me figures it out. Thanks.

Collaborator

carlosantoniodasilva commented Feb 6, 2011

Please try the 0.2.4 version to see if that works for you.

hazah commented Mar 19, 2011

0.2.4 has the same problem for me.

Yes, the same problem in 0.2.4
My haml for example

= show_for @line do |l|
    = l.attribute :name, :label => false, :content_tag => :h2

renders in escaped html
<p class="wrapper line_name">&lt;h2 class="content"&gt;LineName&lt;/h2&gt;</p>

Collaborator

carlosantoniodasilva commented Aug 17, 2011

Hey @kugaevsky, could you try out a patch please?
We've been quite busy here to work on that right now. Let us know if you have any doubt, thanks.

At.
Carlos A. da Silva

On Wednesday, August 17, 2011 at 2:41 PM, kugaevsky wrote:

Yes, the same problem in 0.2.4
My haml for example

= show_for @line do |l|
= l.attribute :name, :label => false, :content_tag => :h2

renders in escaped html
<p class="wrapper line_name">&lt;h2 class="content"&gt;LineName&lt;/h2&gt;</p>

Reply to this email directly or view it on GitHub:
#11 (comment)

@nashby nashby added a commit to nashby/show_for that referenced this issue Jan 25, 2012

@nashby nashby fix issue #11 81aec3e

nashby referenced this issue Jan 25, 2012

Merged

fix issue #11 #35

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment