Permalink
Browse files

Now we only support Rails 4

  • Loading branch information...
1 parent 803b3c4 commit 0c72fc1d7a9b45bb5fe7406005e6565cc8415503 @rafaelfranca rafaelfranca committed Dec 13, 2012
Showing with 48 additions and 47 deletions.
  1. +4 −3 Gemfile
  2. +42 −42 Gemfile.lock
  3. +2 −2 simple_form.gemspec
View
@@ -3,9 +3,10 @@ source :rubygems
gemspec
gem 'country_select'
-gem 'railties', '~> 3.2.0'
-gem 'activemodel', '~> 3.2.0'
-gem 'actionpack', '~> 3.2.0'
+gem 'railties', '>= 4.0.0.beta', '< 4.1', github: 'rails/rails', branch: 'master'
+gem 'activemodel', '>= 4.0.0.beta', '< 4.1', github: 'rails/rails', branch: 'master'
+gem 'actionpack', '>= 4.0.0.beta', '< 4.1', github: 'rails/rails', branch: 'master'
+gem 'journey', github: 'rails/journey'
gem 'rake'
gem 'rdoc'
gem 'mocha', :require => false
View
@@ -1,75 +1,75 @@
+GIT
+ remote: git://github.com/rails/journey.git
+ revision: 5e14f7477b3d05595bf950b33812793da2c3913c
+ specs:
+ journey (2.0.0.20120723141804)
+
+GIT
+ remote: git://github.com/rails/rails.git
+ revision: ae68fc3864e99ab43c18fd12577744e1583f6b64
+ branch: master
+ specs:
+ actionpack (4.0.0.beta)
+ activesupport (= 4.0.0.beta)
+ builder (~> 3.1.0)
+ erubis (~> 2.7.0)
+ journey (~> 2.0.0)
+ rack (~> 1.4.1)
+ rack-test (~> 0.6.1)
+ activemodel (4.0.0.beta)
+ activesupport (= 4.0.0.beta)
+ builder (~> 3.1.0)
+ activesupport (4.0.0.beta)
+ i18n (~> 0.6)
+ minitest (~> 4.1)
+ multi_json (~> 1.3)
+ tzinfo (~> 0.3.33)
+ railties (4.0.0.beta)
+ actionpack (= 4.0.0.beta)
+ activesupport (= 4.0.0.beta)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (>= 0.15.4, < 2.0)
+
PATH
remote: .
specs:
simple_form (3.0.0.dev)
- actionpack (~> 3.0)
- activemodel (~> 3.0)
+ actionpack (>= 4.0.0.beta, < 4.1)
+ activemodel (>= 4.0.0.beta, < 4.1)
GEM
remote: http://rubygems.org/
specs:
- actionpack (3.2.9)
- activemodel (= 3.2.9)
- activesupport (= 3.2.9)
- builder (~> 3.0.0)
- erubis (~> 2.7.0)
- journey (~> 1.0.4)
- rack (~> 1.4.0)
- rack-cache (~> 1.2)
- rack-test (~> 0.6.1)
- sprockets (~> 2.2.1)
- activemodel (3.2.9)
- activesupport (= 3.2.9)
- builder (~> 3.0.0)
- activesupport (3.2.9)
- i18n (~> 0.6)
- multi_json (~> 1.0)
- builder (3.0.4)
+ builder (3.1.4)
country_select (1.0.1)
erubis (2.7.0)
- hike (1.2.1)
i18n (0.6.1)
- journey (1.0.4)
json (1.7.5)
metaclass (0.0.1)
+ minitest (4.3.3)
mocha (0.13.0)
metaclass (~> 0.0.1)
- multi_json (1.3.7)
+ multi_json (1.5.0)
rack (1.4.1)
- rack-cache (1.2)
- rack (>= 0.4)
- rack-ssl (1.3.2)
- rack
rack-test (0.6.2)
rack (>= 1.0)
- railties (3.2.9)
- actionpack (= 3.2.9)
- activesupport (= 3.2.9)
- rack-ssl (~> 1.3.2)
- rake (>= 0.8.7)
- rdoc (~> 3.4)
- thor (>= 0.14.6, < 2.0)
rake (10.0.1)
rdoc (3.12)
json (~> 1.4)
- sprockets (2.2.1)
- hike (~> 1.2)
- multi_json (~> 1.0)
- rack (~> 1.0)
- tilt (~> 1.1, != 1.3.0)
thor (0.16.0)
- tilt (1.3.3)
tzinfo (0.3.35)
PLATFORMS
ruby
DEPENDENCIES
- actionpack (~> 3.2.0)
- activemodel (~> 3.2.0)
+ actionpack (>= 4.0.0.beta, < 4.1)!
+ activemodel (>= 4.0.0.beta, < 4.1)!
country_select
+ journey!
mocha
- railties (~> 3.2.0)
+ railties (>= 4.0.0.beta, < 4.1)!
rake
rdoc
simple_form!
View
@@ -19,6 +19,6 @@ Gem::Specification.new do |s|
s.rubyforge_project = "simple_form"
- s.add_dependency('activemodel', '~> 3.0')
- s.add_dependency('actionpack', '~> 3.0')
+ s.add_dependency('activemodel', '>= 4.0.0.beta', '< 4.1')
+ s.add_dependency('actionpack', '>= 4.0.0.beta', '< 4.1')
end

6 comments on commit 0c72fc1

@rafaelfranca in the future, please consider a "transitional" release that supports both major versions of rails (eg. 3 and 4), if possible. Jumping directly makes the rails 4 upgrade slightly more difficult for simple_form users. Thanks!

Collaborator

rafaelfranca replied Jan 31, 2014

We didn't need to. The 2.1 version still support Rails 3.

Collaborator

rafaelfranca replied Jan 31, 2014

Just to be clear, both Simple Form 3.0 and 2.1 have the same features so we didn't need a "transitional" release.

Sorry, I don't understand. simple_form 2.1 has the following dependencies:

  s.add_dependency('activemodel', '~> 3.0')
  s.add_dependency('actionpack', '~> 3.0')

Is there a release that supports both rails 3 and 4?

Collaborator

rafaelfranca replied Feb 3, 2014

Sorry for the ping on this commit, but is it possible to run simple form 2.1 with bootstrap3? couldn't find a proper instruction... :/

Please sign in to comment.