Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge pull request #958 from petergoldstein/feature/add_jruby_and_rbx

JRuby and Rubinius support in specs, Travis
  • Loading branch information...
commit 6ce9a15a5abbd17f82fe4a0173fcfe676b0a2138 2 parents c8d7dfb + 3bcb1c9
@rafaelfranca rafaelfranca authored
View
2  .travis.yml
@@ -2,6 +2,8 @@ language: ruby
rvm:
- 1.9.3
- 2.0.0
+ - rbx
+ - jruby-19mode
gemfile:
- gemfiles/Gemfile.rails-head
- Gemfile
View
7 Gemfile
@@ -2,10 +2,15 @@ source 'https://rubygems.org'
gemspec
+platforms :rbx do
+ gem 'rubysl', '~> 2.0'
+ gem 'rubinius-developer_tools'
+end
+
gem 'country_select', '~> 1.1.1'
gem 'railties', github: 'rails/rails', branch: '4-0-stable'
gem 'activemodel', github: 'rails/rails', branch: '4-0-stable'
gem 'actionpack', github: 'rails/rails', branch: '4-0-stable'
gem 'rake'
-gem 'rdoc'
gem 'tzinfo'
+gem 'rdoc'
View
67 Gemfile.lock
@@ -1,67 +0,0 @@
-GIT
- remote: git://github.com/rails/rails.git
- revision: b632a8237745c62747558551c74e32a3bb056e09
- branch: 4-0-stable
- specs:
- actionpack (4.0.2)
- activesupport (= 4.0.2)
- builder (~> 3.1.0)
- erubis (~> 2.7.0)
- rack (~> 1.5.2)
- rack-test (~> 0.6.2)
- activemodel (4.0.2)
- activesupport (= 4.0.2)
- builder (~> 3.1.0)
- activesupport (4.0.2)
- i18n (~> 0.6, >= 0.6.4)
- minitest (~> 4.2)
- multi_json (~> 1.3)
- thread_safe (~> 0.1)
- tzinfo (~> 0.3.37)
- railties (4.0.2)
- actionpack (= 4.0.2)
- activesupport (= 4.0.2)
- rake (>= 0.8.7)
- thor (>= 0.18.1, < 2.0)
-
-PATH
- remote: .
- specs:
- simple_form (3.0.1)
- actionpack (>= 4.0.0, < 4.1)
- activemodel (>= 4.0.0, < 4.1)
-
-GEM
- remote: https://rubygems.org/
- specs:
- atomic (1.1.14)
- builder (3.1.4)
- country_select (1.1.3)
- erubis (2.7.0)
- i18n (0.6.9)
- json (1.8.1)
- minitest (4.7.5)
- multi_json (1.8.2)
- rack (1.5.2)
- rack-test (0.6.2)
- rack (>= 1.0)
- rake (10.1.0)
- rdoc (4.0.1)
- json (~> 1.4)
- thor (0.18.1)
- thread_safe (0.1.3)
- atomic
- tzinfo (0.3.38)
-
-PLATFORMS
- ruby
-
-DEPENDENCIES
- actionpack!
- activemodel!
- country_select (~> 1.1.1)
- railties!
- rake
- rdoc
- simple_form!
- tzinfo
View
20 Rakefile
@@ -3,7 +3,6 @@
require 'bundler/gem_tasks'
require 'rake/testtask'
-require 'rdoc/task'
desc 'Default: run unit tests.'
task default: :test
@@ -16,11 +15,16 @@ Rake::TestTask.new(:test) do |t|
t.verbose = true
end
-desc 'Generate documentation for the simple_form plugin.'
-RDoc::Task.new(:rdoc) do |rdoc|
- rdoc.rdoc_dir = 'rdoc'
- rdoc.title = 'SimpleForm'
- rdoc.options << '--line-numbers'
- rdoc.rdoc_files.include('README.md')
- rdoc.rdoc_files.include('lib/**/*.rb')
+begin
+ require 'rdoc/task'
+ desc 'Generate documentation for the simple_form plugin.'
+ RDoc::Task.new(:rdoc) do |rdoc|
+ rdoc.rdoc_dir = 'rdoc'
+ rdoc.title = 'SimpleForm'
+ rdoc.options << '--line-numbers'
+ rdoc.rdoc_files.include('README.md')
+ rdoc.rdoc_files.include('lib/**/*.rb')
+ end
+rescue LoadError
+ puts 'RDoc::Task is not supported on this platform'
end
View
6 gemfiles/Gemfile.rails-head
@@ -2,10 +2,14 @@ source 'https://rubygems.org'
gemspec :path => '..'
+platforms :rbx do
+ gem 'rubysl', '~> 2.0'
+ gem 'rubinius-developer_tools'
+end
+
gem 'country_select', '~> 1.1.1'
gem 'railties', github: 'rails/rails'
gem 'activemodel', github: 'rails/rails'
gem 'actionpack', github: 'rails/rails'
gem 'rake'
-gem 'rdoc'
gem 'tzinfo'
Please sign in to comment.
Something went wrong with that request. Please try again.