Permalink
Commits on Apr 4, 2017
  1. Merge pull request #1479 from tricknotes/update-ruby-versions

    Update Ruby versions on Travis CI
    rafaelfranca committed on GitHub Apr 4, 2017
Commits on Mar 24, 2017
  1. Merge pull request #1474 from rafamoreira/patch-1

    Fix minor typos in Foundation Initializer
    carlosantoniodasilva committed on GitHub Mar 24, 2017
Commits on Mar 8, 2017
  1. Merge pull request #1471 from Guv0/readme-typo

    Minor typo fixed in README
    nashby committed on GitHub Mar 8, 2017
  2. Minor typo fixed in README

    Guv0 committed Mar 8, 2017
Commits on Feb 27, 2017
  1. Merge pull request #1470 from VonTeacher/readme-grammar-fix-1

    Fix grammar errors (correct PR)
    nashby committed on GitHub Feb 27, 2017
  2. Fix grammar errors

    Changes made to lines 217 and 1060 as per Issue #1468 (two typo edit suggestions)
    VonTeacher committed on GitHub Feb 27, 2017
Commits on Feb 22, 2017
  1. Merge pull request #1467 from artfuldodger/patch-2

    Fix readme typo
    rafaelfranca committed on GitHub Feb 22, 2017
  2. Fix readme typo

    artfuldodger committed on GitHub Feb 22, 2017
Commits on Jan 6, 2017
  1. Release 3.4.0.

    lucasmazza committed Jan 6, 2017
  2. Update CHANGELOG [ci skip]

    lucasmazza committed Jan 6, 2017
  3. Merge pull request #1454 from jcoyne/ruby_2.4

    Add Ruby 2.4 to the test matrix
    lucasmazza committed on GitHub Jan 6, 2017
  4. Merge pull request #1455 from braingourmets/task/old-rubies

    [TASK] Drop support for Ruby 1.9.x
    lucasmazza committed on GitHub Jan 6, 2017
  5. Merge pull request #1451 from takkanm/remove_Fixnum_and_Bignum_deprec…

    …ated_warning
    
    remove Fixnum and Bignum deprecated warning
    lucasmazza committed on GitHub Jan 6, 2017
Commits on Jan 5, 2017
  1. Add Ruby 2.4 to the test matrix

    Ensure that old rubies use Nokogiri 1.6.8
    Fixes #1453
    jcoyne committed Jan 5, 2017
  2. [TASK] Drop support for Ruby 1.9.x

    Ruby 1.9.3 was end-of-lifed on 2015-02-23.
    oliverklee committed Jan 5, 2017
Commits on Jan 4, 2017
  1. add compatibility comment

    thanks @janpieper
    takkanm committed Jan 4, 2017
Commits on Dec 29, 2016
Commits on Nov 16, 2016
  1. Update CHANGELOG.

    lucasmazza committed Nov 16, 2016
  2. Merge pull request #1418 from ajb/specify-boolean-label-class-for-ind…

    …ividual-input
    
    specify :boolean_label_class on a per-input basis
    lucasmazza committed on GitHub Nov 16, 2016
  3. Merge pull request #1420 from sethveale/master

    Added Minlength validation with tests a la Maxlength
    lucasmazza committed on GitHub Nov 16, 2016
Commits on Oct 5, 2016
  1. Merge pull request #1434 from artfuldodger/patch-1

    Fix typo
    nashby committed on GitHub Oct 5, 2016
  2. Fix typo

    artfuldodger committed on GitHub Oct 5, 2016
Commits on Aug 26, 2016
  1. Release 3.3.1.

    lucasmazza committed Aug 26, 2016
  2. Merge pull request #1422 from tjgrathwell/stringify-argument-to-type_…

    …for_attribute
    
    Ensure the arg sent to `type_for_attribute` is a string
    lucasmazza committed on GitHub Aug 26, 2016
  3. Ensure the arg sent to `type_for_attribute` is a string

    Per the docs, it is required to be a string:
    http://api.rubyonrails.org/v5.0.0/classes/ActiveRecord/ModelSchema/ClassMethods.html#method-i-type_for_attribute
    
    If you send a symbol, you will get an empty
    ActiveRecord::Type::Value instance instead of the actual
    column type you might have expected.
    
    Since `f.input [attr]` can otherwise be invoked with
    either a symbol or string, it seems important to
    support both.
    
    Fixes #1421
    tjgrathwell committed Aug 26, 2016
Commits on Aug 25, 2016
  1. Release 3.3.0.

    lucasmazza committed Aug 25, 2016
  2. Update CHANGELOG.

    lucasmazza committed Aug 25, 2016
  3. Merge pull request #1417 from plataformatec/lm-activemodel-type-api

    Support the ActiveModel::Type API when available
    lucasmazza committed on GitHub Aug 25, 2016
  4. Merge pull request #1416 from petrgazarov/do-not-ignore-implicitly-pa…

    …ssed-required-option
    
    Do not ignore implicitly passed required option
    lucasmazza committed on GitHub Aug 25, 2016
Commits on Aug 22, 2016
  1. ATTRIBUTE_COMPONENTS includes minlength now

    Seth Veale committed Aug 22, 2016