New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rails 5.2.0 upgrade causes "Undefined method `wrapper' for SimpleForm:Module" error #1568

Closed
gregblass opened this Issue Apr 10, 2018 · 6 comments

Comments

Projects
None yet
4 participants
@gregblass

gregblass commented Apr 10, 2018

Just updated to the Rails 5.2.0 release, but I can't start my rails server:

/myapp/config/initializers/simple_form.rb:8:in `block in <top (required)>': undefined method `wrappers' for SimpleForm:Module (NoMethodError)
Did you mean?  wrapper_class
	from /.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/simple_form-1.4.1/lib/simple_form.rb:143:in `setup'
	from /myapp/config/initializers/simple_form.rb:2:in `<top (required)>'
@gregblass

This comment has been minimized.

gregblass commented Apr 10, 2018

This might be related to #1567. When I did bundle update, it stuck with 3.5.0. I see that 3.5.1 has been released, plus some commits after that...but when trying to install 3.5.1, or the latest from the github branch, it looks like the requirements in #1567 are limiting it. So if this has been fixed downstream, feel free to close.

@KeithP

This comment has been minimized.

KeithP commented Apr 10, 2018

@gregblass it is normal for simple_form to have a delayed update after a Rails upgrade. Until #1567 is done, if you go back to this in your gemfile it should work:
gem 'rails', '~> 5.2.0.beta2'

@gregblass

This comment has been minimized.

gregblass commented Apr 10, 2018

Sure thing. That is what I did. I'm using RBENV so it was painless to go back. Thanks for the info though.

@doits

This comment has been minimized.

doits commented Apr 10, 2018

When you upgrade to Rails 5.2.0 (non -rc and -beta), it will fetch simple form 1.4.1, since it was the latest version released without rails version restriction (see https://rubygems.org/gems/simple_form/versions/1.4.1). This of course does not work and gives weird errors.

Staying at Rails 5.2 beta or rc (eg. 5.2.0.rc2) allows to install simple form 3.5.1, since it has the restriction < 5.2, and 5.2.0.rc2 < 5.2 in semver.

@feliperenan

This comment has been minimized.

Contributor

feliperenan commented Apr 11, 2018

We released a new version of Simple Form just now. Could you update the gem to the last version and comment on this issue if something goes wrong?

@KeithP

This comment has been minimized.

KeithP commented Apr 11, 2018

upgrade now works for us thanks @feliperenan

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment