Deprecation Warning #436

Closed
seivan opened this Issue Feb 4, 2012 · 6 comments

Projects

None yet

4 participants

@seivan
seivan commented Feb 4, 2012

SimpleForm.wrapper_error_class
=> "DEPRECATION WARNING: [SIMPLE_FORM] SimpleForm.wrapper_error_class is deprecated and has no effect. (called from wrapper_error_class at (eval):1)"

I'm trying to get Simple Form 2 to work nicely with client_side_validations.
Any idea on what the alternatives are to get error classes and etc?

@nashby
Collaborator
nashby commented Feb 4, 2012

read about migrating to Simple Form 2 here https://github.com/plataformatec/simple_form/wiki/Upgrading-to-Simple-Form-2.0 And please use mailing list or stackoverflow for such questions. Thanks ❤️

@seivan
seivan commented Feb 4, 2012

Alright thanks for the heads up.
Though you should know that the upgrade actually does not mention what the replacement is in code.
I more or less got to experiment my way forward in to finding the replacements
SimpleForm.wrapper(:bootstrap)
SimpleForm.wrapper(:bootstrap).defaults
SimpleForm.wrapper(:bootstrap).defaults[:error_class]

Now... hmm how do I get the error_tag (rhetorical, or maybe I should post it on SO)


Med Vänliga Hälsningar // With Best Regards

Seivan Heidari

On Feb 5, 2012, at 4:01 AM, Vasiliy Ermolovich wrote:

read about migrating to Simple Form 2 here https://github.com/plataformatec/simple_form/wiki/Upgrading-to-Simple-Form-2.0 And please use mailing list or stackoverflow for such questions.


Reply to this email directly or view it on GitHub:
#436 (comment)

@seivan
seivan commented Feb 4, 2012

Alright, got it to work nicely.
rafaelfranca/simple_form-bootstrap#4
https://github.com/seivan/client_side_validations-simple_form (very much of hack and is only working with bootstrap as a default wrapper)

@seivan seivan closed this Feb 4, 2012
@carlosantoniodasilva
Collaborator

The wiki should explain how to upgrade the old components setup to the new wrappers api. Please let us know if you think there is something missing there, thanks!

@navneetkapur

Hi am facing the same issue reading wiki i did not get the info how to fix the same

@carlosantoniodasilva
Collaborator

@navneetkapur the wrapper_error_class is now an error_class option with the wrappers api, you have to check on the wiki how to create a new wrapper that matches your 1.5 components setup.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment