'platformio' is not recognized as an internal or external command, operable program or batch file. #138

Closed
captainwasabi opened this Issue Jul 13, 2016 · 7 comments

Comments

Projects
None yet
2 participants
@captainwasabi

captainwasabi commented Jul 13, 2016

Updated platformio

Click on build from the toolbar.

'platformio' is not recognized as an internal or external command,
operable program or batch file.

However, all the commands work fine in the shell.

Windows 10

@ivankravets

This comment has been minimized.

Show comment
Hide comment
@ivankravets

ivankravets Jul 13, 2016

Member

Do you use the latest 1.3.1 version of IDE?

It should be fixed here #134

Member

ivankravets commented Jul 13, 2016

Do you use the latest 1.3.1 version of IDE?

It should be fixed here #134

@ivankravets ivankravets self-assigned this Jul 13, 2016

@captainwasabi

This comment has been minimized.

Show comment
Hide comment
@captainwasabi

captainwasabi Jul 13, 2016

yes, just upgraded this morning. There were some issues and I had to uninstall and reinstall.

yes, just upgraded this morning. There were some issues and I had to uninstall and reinstall.

@ivankravets

This comment has been minimized.

Show comment
Hide comment
@ivankravets

ivankravets Jul 13, 2016

Member

There were some issues

We know about these issues and they are fixed in this 1.3.1. You will not see these errors for the next update


Did it work before with 1.3.0?

Member

ivankravets commented Jul 13, 2016

There were some issues

We know about these issues and they are fixed in this 1.3.1. You will not see these errors for the next update


Did it work before with 1.3.0?

@captainwasabi

This comment has been minimized.

Show comment
Hide comment
@captainwasabi

captainwasabi Jul 13, 2016

also now getting this trying to open a serial monitor:

io -f -c atom serialports monitor --port COM7
could not open port u'COM7': could not open port u'COM7': WindowsError(5, 'Access is denied.')

also now getting this trying to open a serial monitor:

io -f -c atom serialports monitor --port COM7
could not open port u'COM7': could not open port u'COM7': WindowsError(5, 'Access is denied.')

@captainwasabi

This comment has been minimized.

Show comment
Hide comment
@captainwasabi

captainwasabi Jul 13, 2016

Ivan, I am on 1.3.1, that is what I installed. Not sure what version I was on before. I just installed it last week, so probably 1.3.0, and it did work.

IDE 1.3.1 | CLI 2.11.1

captainwasabi commented Jul 13, 2016

Ivan, I am on 1.3.1, that is what I installed. Not sure what version I was on before. I just installed it last week, so probably 1.3.0, and it did work.

IDE 1.3.1 | CLI 2.11.1

@captainwasabi

This comment has been minimized.

Show comment
Hide comment
@captainwasabi

captainwasabi Jul 13, 2016

solved. Atom wasn't upgrading to latest. I'll leave this open for your notes.

solved. Atom wasn't upgrading to latest. I'll leave this open for your notes.

@ivankravets

This comment has been minimized.

Show comment
Hide comment
@ivankravets

ivankravets Jul 13, 2016

Member

Thanks, we are working on the new installers for PlatformIO IDE with the latest Atom 1.8.0

Member

ivankravets commented Jul 13, 2016

Thanks, we are working on the new installers for PlatformIO IDE with the latest Atom 1.8.0

@ivankravets ivankravets modified the milestone: 1.3.4 Jul 21, 2016

ivankravets added a commit that referenced this issue Jul 21, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment