New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to install platformio on Rasberry Pi Raspian Stretch #1017

Closed
blackketter opened this Issue Aug 17, 2017 · 4 comments

Comments

Projects
None yet
2 participants
@blackketter

blackketter commented Aug 17, 2017

What kind of issue is this?

  • PlatformIO Core. If you’ve found a bug, please provide an information below.

Configuration

Operating system:
Raspian Stretch

PlatformIO Version (platformio --version):
Current release, 3.4.1

Description of problem

Attempting to install Platformio on fresh Raspian Stretch release.

Steps to Reproduce

  1. succeeds:
    pip install -U platformio

  2. fails:
    sudo python -c "$(curl -fsSL https://raw.githubusercontent.com/platformio/platformio/master/scripts/get-platformio.py)"

Actual Results

pi@raspberrypi:~ $ sudo python -c "$(curl -fsSL https://raw.githubusercontent.com/platformio/platformio/master/scripts/get-platformio.py)"

==> Installing Python Package Manager ...
Requirement already up-to-date: pip in /usr/lib/python2.7/dist-packages

[SUCCESS]

==> Installing PlatformIO and dependencies ...

/usr/bin/python: can't open file 'pip': [Errno 2] No such file or directory

[FAILURE]
The installation process has been FAILED!
Please report about this problem here
< https://github.com/platformio/platformio-core/issues >
@ivankravets

This comment has been minimized.

Member

ivankravets commented Aug 17, 2017

sudo python -c "$(curl -fsSL https://raw.githubusercontent.com/platformio/platformio/master/scripts/get-platformio.py)"

Where did you find this link?

This is really a bug in our installer. We fixed in develop version. Try to replace master with develop in that URL.

@ivankravets

This comment has been minimized.

Member

ivankravets commented Aug 17, 2017

Indeed, issue was fixed in 9b2e7bf

I see a few links on Installation page which lead to "master". I'll replace them to "develop".

Thanks a lot for the report!

@ivankravets ivankravets added this to the 3.5.0 milestone Aug 17, 2017

@ivankravets ivankravets added bug and removed duplicate labels Aug 17, 2017

@blackketter

This comment has been minimized.

blackketter commented Aug 17, 2017

I believe I grabbed that link from the http://docs.platformio.org/en/latest/installation.html page, but I can't be sure now, since that appears to have "develop" in it now. Did you change the docs?

I think I just hit DuckDuckGo with "install platformio cli"

I'm further confused by the title of that page being "<title>Installation — PlatformIO 3.5.0a4 documentation</title>". :)

@ivankravets

This comment has been minimized.

Member

ivankravets commented Aug 18, 2017

Yes, yes, I fixed links in docs :) Thanks!

ivankravets added a commit that referenced this issue Dec 28, 2017

Bump version to 3.5.0 (issue #1260, issue #781, issue #778, issue #463,…
… issue #1236, issue #1235, issue #953, issue #1118, issue #1107, issue #1196, issue #1179, issue #1161, issue #1126, issue #104, issue #1033, issue #1034, issue #1175, issue #1173, issue #1155, issue #1188, issue #1111, issue #1153, issue #1150, issue #1145, issue #1139, issue #1137, issue #1170, issue #1157, issue #1102, issue #1105, issue #1140, issue #1154, issue #1066, issue #1038, issue #1054, issue #1055, issue #1061, issue #1017)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment