New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Library Storage: Could not extract #2015

Closed
Nullfati opened this Issue Jan 2, 2019 · 4 comments

Comments

Projects
None yet
2 participants
@Nullfati
Copy link

Nullfati commented Jan 2, 2019

PIO Core Call Error: "Library Storage: C:\Users\Nullfati\.platformio\lib\r\nLibraryManager: Installing id=5784\r\nDownloading...\r\nUnpacking\r\nUnpacking\n\nError: Could not extract ./tools/esp-idf/version_finder.mk to C:\\Users\\Nullfati\\.platformio\\lib\\_tmp_installing-zhm3ck-package. Try to disable antivirus tool or check this solution -> http://bit.ly/faq-package-manager"

@ivankravets

This comment has been minimized.

Copy link
Member

ivankravets commented Jan 9, 2019

Do you use antivirus tool in system?

@ivankravets ivankravets changed the title Home: Libraries: Could not install library Library Storage: Could not extract Jan 9, 2019

@Nullfati

This comment has been minimized.

Copy link

Nullfati commented Jan 9, 2019

I disabled antivirus for a clear test.
Maybe a found a problem. File version_finder.mk is a symbolic link and in Unix, it's library install okay. (this is just my guess and I may be wrong.)

@ivankravets ivankravets added bug lib and removed help wanted labels Jan 9, 2019

@ivankravets

This comment has been minimized.

Copy link
Member

ivankravets commented Jan 9, 2019

Yes, this is a bug. I can reproduce it.

@ivankravets ivankravets added this to the 3.6.4 milestone Jan 10, 2019

@ivankravets

This comment has been minimized.

Copy link
Member

ivankravets commented Jan 10, 2019

The bug has been fixed. Please

  1. Switch PIO Core in PlatformIO IDE to development version https://docs.platformio.org/en/latest/ide/vscode.html#platformio-ide-usedevelopmentpiocore
  2. Open PIO IDE Terminal and type pio upgrade --dev. It should be 4.0.0a1.

Does it work now?

ivankravets added a commit that referenced this issue Jan 10, 2019

Fix an error "Could not extract item..." when extracting TAR archive …
…with symbolic items on Windows platform // Resolve #2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment