New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

esp12e nodeMCU OSX fails to upload a basic example #380

Closed
aperepel opened this Issue Dec 16, 2015 · 8 comments

Comments

Projects
None yet
3 participants
@aperepel

aperepel commented Dec 16, 2015

Hi, trying out the most basic blinky example with PlatformIO. Everything works fine with ArduinoIDE as well as Eclipse Arduino. I, however, am running into issues with PlatformIO (the code is the most basic blink/delay):

platformio run --target upload
[Wed Dec 16 15:43:50 2015] Processing esp12e (platform: espressif, board: esp12e, framework: arduino)
-----------------------------------------------------------------------------------------------------------------------
BeforeUpload(["upload"], [".pioenvs/esp12e/firmware.bin"])
Auto-detected UPLOAD_PORT/DISK: /dev/cu.wchusbserial1410
/Users/agrande/.platformio/packages/tool-esptool/esptool -vv -cd ck -cb 115200 -cp /dev/cu.wchusbserial1410 -ca 0x00000 -cf .pioenvs/esp12e/firmware.bin
esptool v0.4.5 - (c) 2014 Ch. Klippel <ck@atelier-klippel.de>
setting board to ck
setting baudrate from 115200 to 115200
setting port from /dev/tty.usbserial to /dev/cu.wchusbserial1410
setting address from 0x00000000 to 0x00000000
espcomm_upload_file
stat .pioenvs/esp12e/firmware.bin success
opening port /dev/cu.wchusbserial1410 at 115200
tcgetattr
tcsetattr
serial open
opening bootloader
resetting board
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
scons: *** [upload] Error 255
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
resetting board
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
resetting board
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
trying to connect
setting character timeout 0
done
setting character timeout 1
done
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
warning: espcomm_sync failed
error: espcomm_open failed
============================================= [ ERROR ] Took 3.11 seconds =============================================
@ivankravets

This comment has been minimized.

Member

ivankravets commented Dec 16, 2015

Thanks, will fix it ASAP.

@ivankravets ivankravets added this to the 2.6.1 milestone Dec 16, 2015

@ivankravets ivankravets self-assigned this Dec 16, 2015

@ivankravets

This comment has been minimized.

Member

ivankravets commented Dec 16, 2015

@ivankravets ivankravets reopened this Dec 16, 2015

@ivankravets

This comment has been minimized.

Member

ivankravets commented Dec 16, 2015

Don't forget to $ platformio update all packages

@ivankravets ivankravets changed the title from esp12e OSX fails to upload a basic example to esp12e nodeMCU OSX fails to upload a basic example Dec 16, 2015

@aperepel

This comment has been minimized.

aperepel commented Dec 16, 2015

Thanks! This worked. Appreciate a prompt fix.

@ivankravets

This comment has been minimized.

Member

ivankravets commented Dec 16, 2015

Which is type of your board? NodeMCU?

@aperepel

This comment has been minimized.

aperepel commented Dec 17, 2015

Yes, that's the one.

ivankravets added a commit that referenced this issue Dec 18, 2015

@ivankravets

This comment has been minimized.

Member

ivankravets commented Dec 18, 2015

@aperepel PlatformIO 2.6.1 is released! Please upgrade https://github.com/platformio/platformio/releases/tag/v2.6.1

@zdebord

This comment has been minimized.

zdebord commented Aug 17, 2016

Same problem for the Expressif ESP-01:

espcomm_send_command: sending command header
espcomm_send_command: sending command payload
warning: espcomm_sync failed
error: espcomm_open failed

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment