New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add please Arduino Boards from arduino.org #472

Closed
sstaub opened this Issue Jan 25, 2016 · 20 comments

Comments

Projects
None yet
6 participants
@sstaub

sstaub commented Jan 25, 2016

Please can you add the boards from the alternativ Arduino Company arduino.org

  • Leonardo ETH
  • M0
  • M0 Pro

sstaub

@choidamdam

This comment has been minimized.

choidamdam commented Feb 3, 2016

+1
maybe we should create separate framework something like arduino.org.

@ivankravets

This comment has been minimized.

Member

ivankravets commented Feb 3, 2016

I contacted with Arduino.Org and waiting for the further information. I'll write here about all news.

@choidamdam

This comment has been minimized.

choidamdam commented Mar 17, 2016

There are some new arduino.org-only boards:

@ivankravets ivankravets modified the milestone: 2.9.0 Mar 19, 2016

@aethaniel

This comment has been minimized.

aethaniel commented Mar 23, 2016

@valeros, this ticket should not be labelled vendor:atmel 😉

@ivankravets

This comment has been minimized.

Member

ivankravets commented Mar 23, 2016

@aethaniel thanks 👍 I've just removed 😊

@ivankravets ivankravets modified the milestones: 2.10.0, 3.0.0 Apr 9, 2016

@ivankravets ivankravets modified the milestones: 2.9.0, 3.0.0 Apr 26, 2016

ivankravets added a commit that referenced this issue Apr 28, 2016

@ivankravets

This comment has been minimized.

Member

ivankravets commented Apr 28, 2016

PlatformIO 2.9.0:

  • Added support for Arduino.Org boards: Arduino Leonardo ETH, Arduino Yun Mini, Arduino Industrial 101 and Linino One

ivankravets added a commit that referenced this issue Apr 28, 2016

@ivankravets ivankravets modified the milestone: 2.9.0 Apr 28, 2016

@hgijeon

This comment has been minimized.

hgijeon commented May 13, 2016

I couldn't find neither 'M0' nor 'M0 pro' in boards list.
Could you add those boards?

@valeros valeros added this to the 2.10.4 milestone Jun 20, 2016

@ivankravets

This comment has been minimized.

Member

ivankravets commented Jun 24, 2016

@sstaub @choidamdam @hgijeon ,

Do you have these boards?

  • Arduino Tian
  • M0
  • M0 Pro

We would ask you to test this issue. Thanks!

@sstaub

This comment has been minimized.

sstaub commented Jun 24, 2016

Hi Ivan,
I have a M0 Pro board from arduino.org http://arduino.org/ and I can test it

Regards

Stefan Staub

Am 24.06.2016 um 10:56 schrieb Ivan Kravets notifications@github.com:

@sstaub https://github.com/sstaub @choidamdam https://github.com/choidamdam @hgijeon https://github.com/hgijeon ,

Do you have these boards?

Arduino Tian
M0
M0 Pro
We would ask you to test this issue. Thanks!


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub #472 (comment), or mute the thread https://github.com/notifications/unsubscribe/AGJslXbaJ9n4jj7vUpO0GkFc0GMkhhXjks5qO5urgaJpZM4HLp53.

valeros added a commit that referenced this issue Jun 24, 2016

@valeros

This comment has been minimized.

Member

valeros commented Jun 24, 2016

Hi @sstaub !
It would be great if you could test it. Please follow next steps:

  1. Install PlatformIO from this branch:
    pip install -U https://github.com/platformio/platformio/archive/feature/arduino-org-samd-issue-472.zip
  2. Put this file to ldscripts package in your PlatformIO home directory:
    ~/.platformio/packages/ldscripts
  3. Try uploading to different ports (mzero_pro_dbg board for programming port, mzero_pro for native port)

Thanks in advance!

@sstaub

This comment has been minimized.

sstaub commented Jun 24, 2016

Hi Valerii,
I installed the items as you told. I hope the version is right (what the cmd to check the installed version?).
The file in 2., I copied the content manually in my text editor (mac), I hope this is ok, maybe you send me
this .ld file as an attachment.
So, I started:

  1. There is no board „M0“ or „M0 pro“ only „Zero“
  2. I tried Zero (Programing Port“
    • I need manually „Rebuild C/C++ Project Index“ because aruino.h is not found
    • building Ok
    • upload -> see screenshot, the board stops working
  3. I tried "Zero (USB Native Port)“
    • I need manually „Rebuild C/C++ Project Index“ because aruino.h is not found,
      after changing the board, the proceed of automatic rebuild doesn’t work
    • building Ok
    • upload -> see screenshot, one led is blinking very fast (so it seems there is an upload) but nothing happened

The upload generally works only with Arduino Studio (alpha 0.5) from arduino.org http://arduino.org/, when trying upload with
Arduin 1.6.9 fails because the Arduino IDE can’t find the USB port. There are some special differences
between M0 and Zero, they are not compatible.

Regrads

Stefan Staub

Am 24.06.2016 um 20:08 schrieb Valerii Koval notifications@github.com:

Hi @sstaub https://github.com/sstaub !
It would be great if you could test it. Please follow next steps:

Install PlatformIO from this branch: pip install -U https://github.com/platformio/platformio/archive/feature/arduino-org-samd-issue-472.zip
Put this file https://dl.dropboxusercontent.com/u/10025728/samd21g18a_bootloader_org.ld to ldscripts package in your PlatformIO home directory: /home/user/.platformio/packages/ldscripts
Try uploading to different ports (mzero_pro_dbg board for programming port, mzero_pro for native port)
Thanks in advance!


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub #472 (comment), or mute the thread https://github.com/notifications/unsubscribe/AGJslXJWM-vKtW95NehVcpaoUW_3Vnynks5qPB01gaJpZM4HLp53.

@ivankravets

This comment has been minimized.

Member

ivankravets commented Jun 25, 2016

I installed the items as you told. I hope the version is right (what the cmd to check the installed version?).

Where did you install it? Did you use PlatformIO IDE Terminal?

The file in 2., I copied the content manually in my text editor (mac), I hope this is ok, maybe you send me
this .ld file as an attachment.

Please right click on this link and "Download File..." from a context menu.

There is no board „M0“ or „M0 pro“ only „Zero“

If you use PlatformIO IDE and installed here this test branch, you need to restart IDE.

@sstaub

This comment has been minimized.

sstaub commented Jun 25, 2016

Hi, I installed it first with terminal and today I make a clean install and
make an update to dev. version with build in terminal.
The .ld file can’t downloaded with right click on mail OS X.
Here is the selfdone copy:

The version on home screen is 2.10.3, i expected 2.10.4dev2 ??? the option for using the dev.
version was set. I unset and reset the option, than the version in homescreen is ok 2.10.4dev2.
It seems it is generally a problem when updating via terminal.
The problems are the same like yesterday, It seems that platformio can not find
the usb device. That happens also when I try to upload with the arduino IDE from
arduino.cc http://arduino.cc/ ! It seems that uploading will work with the original „Zero“, but I can’t test it
because the my „M0 pro“ comes from arduino.org http://arduino.org/ !
Maybe you contact the developer team of arduino.org http://arduino.org/ and find someone who have an „original“
zero board.

stefan

PS.: what is the command to check the version

Am 25.06.2016 um 11:35 schrieb Ivan Kravets notifications@github.com:

I installed the items as you told. I hope the version is right (what the cmd to check the installed version?).

Where did you install it? Did you use PlatformIO IDE Terminal?

The file in 2., I copied the content manually in my text editor (mac), I hope this is ok, maybe you send me
this .ld file as an attachment.

Please right click on this link https://dl.dropboxusercontent.com/u/10025728/samd21g18a_bootloader_org.ld and "Download File..." from a context menu.

There is no board „M0“ or „M0 pro“ only „Zero“

If you use PlatformIO IDE and installed here this test branch, you need to restart IDE.


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub #472 (comment), or mute the thread https://github.com/notifications/unsubscribe/AGJslcXO794zdzpNEsxLJUKLqGZKhLtdks5qPPZIgaJpZM4HLp53.

@valeros

This comment has been minimized.

Member

valeros commented Jun 27, 2016

Hi @sstaub ! @ivankravets told me that uploading over avrdude breaks the board.
Could you please replace default arduinosam package /home/user/.platformio/package/framework-arduinosam with this one and try uploading for mzero_pro board (native port)? Any changes?

@sstaub

This comment has been minimized.

sstaub commented Jun 27, 2016

Hi Valerii,
I replaced the file but there is no more upload on native usb port possible, i get a time out:

stefan

Am 27.06.2016 um 12:57 schrieb Valerii Koval notifications@github.com:

Hi @sstaub https://github.com/sstaub ! @ivankravets https://github.com/ivankravets told me that uploading over avrdude breaks the board.
Could you please replace default arduinosam package /home/user/.platformio/package/framework-arduinosam with this one https://www.dropbox.com/s/7dk9x7ou3z6vrl5/framework-arduinosam_m0.zip?dl=0 and try uploading for mzero_pro board (native port)? Any changes?


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub #472 (comment), or mute the thread https://github.com/notifications/unsubscribe/AGJsld4HrnXDKx30S8c-pooOueimtu0wks5qP6yvgaJpZM4HLp53.

@valeros

This comment has been minimized.

Member

valeros commented Jun 27, 2016

@sstaub Have you restored the board?
Would be great if you could try to upload firmware from your terminal via avrdude shipped with Arduino IDE (1.7.10).
Something like that:

/home/user/path_to_arduino_ide/hardware/tools/avr/bin/avrdude -C /home/user/path_to_arduino_ide/hardware/tools/avr/etc/avrdude.conf -v -v -p atmega2560 -c stk500v2 -P /dev/your_device  -b 57600 U flash:w:/home/user/path_to_platformio_project/.pioenvs/env/firmware.hex:i

Thanks for your help!

valeros added a commit that referenced this issue Jun 28, 2016

@ivankravets ivankravets modified the milestones: 2.11.0, 2.11.1 Jun 28, 2016

ivankravets added a commit that referenced this issue Jun 28, 2016

@ivankravets ivankravets referenced this issue Jun 28, 2016

Closed

platformio 2.11.0 #2463

4 of 4 tasks complete

valeros added a commit that referenced this issue Jul 4, 2016

ivankravets added a commit that referenced this issue Jul 4, 2016

@ivankravets

This comment has been minimized.

Member

ivankravets commented Jul 5, 2016

@sstaub @hgijeon,

Please try the latest http://docs.platformio.org/en/latest/installation.html#development-version . Tian, M0 and M0 Pro via USB should work now.

Don't forget to update all packages via platformio update.

Please answer here if it works for you.

@sstaub

This comment has been minimized.

sstaub commented Jul 5, 2016

Hi Ivan
i tested it on the M0 pro and the problem is also the same at the last session,
when uploading code to the native usb-port the boot loader doesn’t work any more,
so I cannot upload the next time. To reset, i have to upload with the arduino.org http://arduino.org/ ide
an usb application over the programming port, then it work for a next try, then it stops again...

Regards

Stefan Staub

Am 05.07.2016 um 15:23 schrieb Ivan Kravets notifications@github.com:

@sstaub https://github.com/sstaub @hgijeon https://github.com/hgijeon,

Please try the latest http://docs.platformio.org/en/latest/installation.html#development-version http://docs.platformio.org/en/latest/installation.html#development-version . Tian, M0 and M0 Pro via USB should work now.

Don't forget to update all packages via platformio update.

Please answer here if it works for you.


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub #472 (comment), or mute the thread https://github.com/notifications/unsubscribe/AGJslbbVAWS4gUsHqUoSeiWQ8NtSvseYks5qSlrYgaJpZM4HLp53.

ivankravets added a commit that referenced this issue Jul 6, 2016

Merge branch 'develop' into feature/platformio-30
* develop: (27 commits)
  Update boards list
  Add Arduino M0 as a separate board
  Update history
  Update microchippic32 platform and boards
  Fix PyLint warning
  Keep user changes for ".gitignore" file when re-generate/update project data
  Documented uploading of EEPROM data
  Push 2.11.1.dev1
  Automatically install dependent upload tools // Issue #472
  Split source files to HEADERS and SOURCES when generate project for Qt Creator IDE // Resolve #713
  Improve project generator for CLion IDE
  Fix missing trailing ``\`` for the source files list when generate project for Qt Creator IDE // Resolve #711
  * Fix missed ``--boot`` flag for the firmware uploader for ATSAM3X8E Cortex-M3 MCU based boards (Arduino Due, etc) // Resolve #710
  Initial support for Arduino M0/Tian boards // Issue #472
  Update project template for Qt Creator // Issue #711
  Fix missed --boot flag for sam3x uploader // Issue # 710
  Auto-remove project cache when PlatformIO is upgraded
  Version bump to 2.11.0 (issues #472, #520, #614, #620, #685, #698, #699)
  Update history
  Update espressif platform according to the new framework version

ivankravets added a commit that referenced this issue Jul 11, 2016

@ivankravets

This comment has been minimized.

Member

ivankravets commented Jul 11, 2016

@sstaub Could I ask you to re-test the latest 2.11.1b1 build with Arduino M0?

  1. PlatformIO IDE Menu: PlatformIO > Upgrade PlatformIO (if it is switched to develop)
  2. PlatformIO IDE Menu: PlatformIO > Update packages

Please check in PlatformIO IDE Terminal pio --version. It should be 2.11.b1.

Thanks.

@ivankravets

This comment has been minimized.

Member

ivankravets commented Jul 11, 2016

@sstaub, @choidamdam, @aethaniel, @hgijeon

Please re-test with the latest development version http://docs.platformio.org/en/latest/installation.html#development-version

If you have any problems, feel free to reopen this issue.

ivankravets added a commit that referenced this issue Jul 12, 2016

@ivankravets ivankravets referenced this issue Jul 12, 2016

Closed

platformio 2.11.1 #2936

4 of 4 tasks complete

ivankravets added a commit that referenced this issue Jul 18, 2016

Merge branch 'develop' into feature/platformio-30
* develop:
  Update docs for Teensy USB Features // Issue #722
  Implement Teensy 2.0 USB functionality (HID, SERIAL_HID, DISK, MIDI, etc.) // Resolve #722
  Add support for Pinoccio Scout board // Resolve #52
  Fix broken LD Script for Element14 chipKIT Pi board // Resolve #725  Resolve #726
  Fix USB flags processing for teensy platform // Issue #722
  Add Pinoccio board // Issue #52
  Minor improvements for CLion docs
  Improved docs for integration with CLion IDE
  Version bump to 2.11.1 (issues #472, #629, #710, #711, #712, #713, #718)
  Typo fix
  Add "udev" rules for OpenOCD CMSIS-DAP adapters // Resolve #718
  Update history
  Ignore "[platformio]" section from custom project configuration CI
  Bump to 2.11.1b1
  Add Arduino M0 Pro and Tian to the examples // Issue #472
  Fix issue when `pioenvs` folder doesn't exist
  Add more info about `.pioenvs` directory
  Improve CMSIS selection for SAMD21 boards
  Improve support for SAMD21 based boards
  Add contributing guidelines
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment