New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Build fails with libraries that are git repositories #49

Closed
aphelps opened this Issue Jan 15, 2015 · 5 comments

Comments

Projects
None yet
3 participants
@aphelps

aphelps commented Jan 15, 2015

I'm making strides to converting my code base to build on platformio, but it seems to not be able to use a library that's within a git repo (ie which I've cloned from elsewhere). I took a look in the platformio line that generated this error, but its not clear to me what the root cause is:

$ platformio run
Processing arduino_nano environment:

scons: *** '/Users/amp/Dropbox/Arduino/HMTL.platformio/HMTL_Module/.pioenvs/arduino_nano/FastLED/refs' already has a source directory: '/Users/amp/Dropbox/Arduino/libraries/FastLED/.git/refs'.
File "/Library/Python/2.7/site-packages/platformio/builder/tools/platformio.py", line 142, in VariantDirRecursive

@ivankravets ivankravets self-assigned this Jan 15, 2015

@ivankravets ivankravets added the bug label Jan 15, 2015

@ivankravets

This comment has been minimized.

Member

ivankravets commented Jan 16, 2015

Give me please a structure of your project. Go to project root dir and type tree -L 3.

@ivankravets

This comment has been minimized.

Member

ivankravets commented Jan 16, 2015

Please test it with the latest develop version:

$ pip uninstall platformio
$ pip install https://github.com/ivankravets/platformio/archive/develop.zip

Does it work for you?

@aphelps

This comment has been minimized.

aphelps commented Jan 17, 2015

Yeah, that fixed the issue. Thanks.

@ivankravets ivankravets added this to the 0.11.0 milestone Jan 21, 2015

@ivankravets ivankravets modified the milestones: 0.11.0, 1.0.0 Feb 9, 2015

@gretel

This comment has been minimized.

gretel commented Feb 13, 2015

@ivankravets, your suggestion worked for me, too. i'd be glad to have this fix mainstream

$ git clone --depth 1 https://github.com/ivankravets/platformio
$ cd platformio
$ pip install -e .
$ pip install --egg scons
@ivankravets

This comment has been minimized.

Member

ivankravets commented Feb 13, 2015

@gretel Thanks a lot for your feedback. We are hardly working on the first stable release 1.0.0. PlatformIO has not been released as stable yet. You can monitor by active issues for 1.0.0 milestone here or follow us via Twitter @PlatformIO_Org.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment