New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

platformio not handling assembly correctly? #58

Closed
aphelps opened this Issue Feb 2, 2015 · 2 comments

Comments

Projects
None yet
2 participants
@aphelps

aphelps commented Feb 2, 2015

Sorry to continue with the "this works under the Arduino IDE but not platformio" topics.

In this one, I'm using an FFT library from https://github.com/adafruit/piccolo which is written in assembly. It looks like platformio does compile it into a library, but may skip a step:

amp@AMP-MBP-home:~/Dropbox/Arduino/ObjectLights/platformio [master]$ platformio run
Processing arduino_nano environment:
avr-g++ -o .pioenvs/arduino_nano/firmware.elf -Os -mmcu=atmega328p -Wl,--gc-sections -Wl,--start-group .pioenvs/arduino_nano/src/Sound.o .pioenvs/arduino_nano/src/SoundCLI.o .pioenvs/arduino_nano/src/SoundUnit.o -L.pioenvs/arduino_nano .pioenvs/arduino_nano/libDebug.a .pioenvs/arduino_nano/libffft.a .pioenvs/arduino_nano/libSerialCLI.a .pioenvs/arduino_nano/libRS485_non_blocking.a .pioenvs/arduino_nano/libSoftwareSerial.a .pioenvs/arduino_nano/libSPI.a .pioenvs/arduino_nano/libFastLED.a .pioenvs/arduino_nano/libHMTLTypes.a .pioenvs/arduino_nano/libPixelUtil.a .pioenvs/arduino_nano/libRS485Utils.a .pioenvs/arduino_nano/libSocket.a .pioenvs/arduino_nano/libMPR121.a .pioenvs/arduino_nano/libWire.a .pioenvs/arduino_nano/libGeneralUtils.a .pioenvs/arduino_nano/libEEPromUtils.a .pioenvs/arduino_nano/libEEPROM.a .pioenvs/arduino_nano/libHMTLMessaging.a .pioenvs/arduino_nano/libHMTLprotocol.a .pioenvs/arduino_nano/libFrameworkArduino.a -lm
.pioenvs/arduino_nano/libffft.a: could not read symbols: Archive has no index; run ranlib to add one
collect2: error: ld returned 1 exit status
scons: *** [.pioenvs/arduino_nano/firmware.elf] Error 1
@ivankravets

This comment has been minimized.

Member

ivankravets commented Feb 2, 2015

Thanks! I've never tested PlatformIO with assembly files. Sorry 😞

Please upgrade your PlatformIO with new develop:
$ pip install https://github.com/ivankravets/platformio/archive/develop.zip

P.S: I've just added new lib Adafruit-LED-Backpack and you can compile https://github.com/adafruit/piccolo/blob/master/Piccolo/Piccolo.pde with the several commands:

# init empty project and copy https://github.com/adafruit/piccolo/blob/master/Piccolo/Piccolo.pde to "src" dir
$ platformio lib install 128
$ platformio run

You don't need to install Adafruit-GFX, this library has pre-defined dependency https://github.com/ivankravets/Adafruit-LED-Backpack-Library/blob/patch-1/library.json

@ivankravets ivankravets added the bug label Feb 2, 2015

@ivankravets ivankravets added this to the 0.11.0 milestone Feb 2, 2015

@ivankravets ivankravets self-assigned this Feb 2, 2015

@aphelps

This comment has been minimized.

aphelps commented Feb 3, 2015

After updating it looks good. Thanks for all the work you're putting into this, I'm pretty excited to be making the switch.

Also thanks for installing that library, although I'm not actually using it in this particular project, I just grabbed their code for the sound sensing ;)

@ivankravets ivankravets modified the milestones: 0.11.0, 1.0.0 Feb 9, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment