Transitive dependencies not installed when installing a library using a git url #913

Closed
chacal opened this Issue Mar 7, 2017 · 0 comments

Comments

Projects
None yet
2 participants
@chacal

chacal commented Mar 7, 2017

Description of problem

It seems that transitive dependencies of libraries do not get installed if the library itself is installed using a git url.

Steps to Reproduce

  1. pio init -b nanoatmega328
  2. pio lib install "r89m PushButton" # Notice all dependencies being installed
  3. rm -rf .piolibdeps/
  4. pio lib install https://github.com/r89m/PushButton.git # Only the library itself is installed

Actual Results

No transitive dependencies are installed.

Expected Results

Transitive dependencies of the library be installed like they are if the library is installed using its name.

Additional info

The installation of the transitive dependencies for libraries installed via git urls would be handy when using own custom libraries that are not published to PIO library repository. See e.g. https://github.com/chacal/esp-mqtt-utils that depends on ArduinoJson, WifiManager and PubSubClient.

Now when I use my ESP-MQTT-utils library in any of my projects, I have to manually install ArduinoJson, WifiManager and PubSubClient to my project in addition to just adding https://github.com/chacal/esp-mqtt-utils.git to my lib_deps

@ivankravets ivankravets added this to the 3.3.0 milestone Mar 8, 2017

@ivankravets ivankravets referenced this issue in Homebrew/homebrew-core Mar 27, 2017

Closed

platformio 3.3.0 #11647

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment