Permalink
Browse files

use Bundler for gem dependency resolution (for local dev only)

  • Loading branch information...
1 parent 98be7a8 commit b425a908adf3ede0b37f34d2329da7d14e97fd2b @fallwith fallwith committed Nov 3, 2011
Showing with 47 additions and 10 deletions.
  1. +4 −10 .rvmrc_example
  2. +7 −0 Gemfile
  3. +36 −0 Gemfile.lock
View
@@ -1,15 +1,9 @@
gemset_name=wsdsl
ruby_version=1.9.2-p290
-rubygems_version=1.8.5
-# specify multiple gems with spaces ex: ('foo 1.2.3' 'bar 5.6.7')
-gems=('jeweler 1.6.4' 'rspec 2.6.0' 'yard 0.7.2' 'rack-test 0.5.7' 'sinatra 1.2.0')
-
-export GIT_SSL_NO_VERIFY=true
+rubygems_version=1.8.10
+bundler_version=1.0.21
rvm use $ruby_version@$gemset_name --create --install
[ $(gem -v) = $rubygems_version ] || rvm rubygems $rubygems_version
-for g in "${gems[@]}"; do
- read n v <<< $(echo $g | awk '{print $1 " " $2}')
- gem list ${n} -v${v} -i >> /dev/null
- [ $? -eq 0 ] || gem install ${n} -v${v} --no-ri --no-rdoc
-done
+gem list bundler -v${bundler_version} -i >/dev/null
+[ $? -eq 0 ] || gem install bundler -v${bundler_version} --no-ri --no-rdoc
View
@@ -0,0 +1,7 @@
+source :rubygems
+
+gem 'jeweler', '1.6.4'
+gem 'rspec', '2.7.0'
+gem 'yard', '0.7.2'
+gem 'rack-test', '0.5.7'
+gem 'sinatra', '1.2.0'
View
@@ -0,0 +1,36 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ diff-lcs (1.1.3)
+ git (1.2.5)
+ jeweler (1.6.4)
+ bundler (~> 1.0)
+ git (>= 1.2.5)
+ rake
+ rack (1.3.5)
+ rack-test (0.5.7)
+ rack (>= 1.0)
+ rake (0.9.2.2)
+ rspec (2.7.0)
+ rspec-core (~> 2.7.0)
+ rspec-expectations (~> 2.7.0)
+ rspec-mocks (~> 2.7.0)
+ rspec-core (2.7.1)
+ rspec-expectations (2.7.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.7.0)
+ sinatra (1.2.0)
+ rack (~> 1.1)
+ tilt (>= 1.2.2, < 2.0)
+ tilt (1.3.3)
+ yard (0.7.2)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ jeweler (= 1.6.4)
+ rack-test (= 0.5.7)
+ rspec (= 2.7.0)
+ sinatra (= 1.2.0)
+ yard (= 0.7.2)

0 comments on commit b425a90

Please sign in to comment.