Permalink
Browse files

republishing for 2.0.2

  • Loading branch information...
1 parent 563dba2 commit 7a539ad7175eb2794905591aaad7a7af7f7de266 @pk11 pk11 committed Jul 5, 2012
View
@@ -5,14 +5,14 @@ This plugin provides build time compilation for [Dust](https://github.com/akduby
# How to install
-
+(requires play 2.0.2)
* add
-```addSbtPlugin("com.typesafe" % "play-plugins-dust" % "1.0-SNAPSHOT")
+```addSbtPlugin("com.typesafe" % "play-plugins-dust" % "1.4")
``` to your dependencies
# How to Use
-* Include dust. Note that this is not provided by the sbt plugin. It can be found here: [dust-core-0.3.0.min.js](https://github.com/akdubya/dustjs/blob/master/dist/dust-core-0.3.0.min.js)
+* Include dust. Note that this is not provided by the sbt plugin. It can be found here: [dust-core-0.6.0.min.js](https://github.com/akdubya/dustjs/blob/master/dist/dust-core-0.3.0.min.js)
```<script src="@routes.Assets.at("javascripts/dust-core-0.6.0.min.js")"></script>
```
@@ -46,4 +46,4 @@ Copyright 2012 Typesafe (http://www.typesafe.com).
Licensed under the Apache License, Version 2.0 (the "License"); you may not use this project except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0.
-Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.
+Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.
View
@@ -4,15 +4,15 @@ sbtPlugin := true
name := "play-plugins-dust"
-version := "1.4-SNAPSHOT"
+version := "1.4"
organization := "com.typesafe"
resolvers += "Typesafe repository" at "http://repo.typesafe.com/typesafe/releases/"
libraryDependencies <++= (scalaVersion, sbtVersion) {
case (scalaVersion, sbtVersion) => Seq(
- sbtPluginExtra("play" % "sbt-plugin" % "2.0", sbtVersion, scalaVersion)
+ sbtPluginExtra("play" % "sbt-plugin" % "2.0.2", sbtVersion, scalaVersion)
)
}
View
@@ -34,9 +34,9 @@ play.Play.application().plugin(InjectPlugin.class).getInstance(MyServiceInterfac
```
# How to install
-
+(requires 2.0.2)
* add
-```"com.typesafe" % "play-plugins-guice" % "2.0.2"``` to your dependencies
+```"com.typesafe" % "play-plugins-guice" % "2.0.3"``` to your dependencies
* create a file called ```play.plugins``` in your ```app/conf``` directory
@@ -3,8 +3,8 @@ import Keys._
object MinimalBuild extends Build {
- lazy val buildVersion = "2.0.2"
- lazy val playVersion = "2.0.1"
+ lazy val buildVersion = "2.0.3"
+ lazy val playVersion = "2.0.2"
View
@@ -116,7 +116,7 @@ play.Play.application().plugin(InjectPlugin.class).getInstance(MyServiceInterfac
```
# How to install
-
+(requires play 2.0.2)
* add
```"com.typesafe" % "play-plugins-inject" % "2.0.2"``` to your dependencies
@@ -3,8 +3,8 @@ import Keys._
object MinimalBuild extends Build {
- lazy val buildVersion = "2.0.2"
- lazy val playVersion = "2.0.1"
+ lazy val buildVersion = "2.0.3"
+ lazy val playVersion = "2.0.2"
lazy val typesafeSnapshot = "Typesafe Snapshots Repository" at "http://repo.typesafe.com/typesafe/snapshots/"
lazy val typesafe = "Typesafe Repository" at "http://repo.typesafe.com/typesafe/releases/"
View
@@ -3,7 +3,9 @@
This plugin provides a simple emailer.
## installation
-* add ```"com.typesafe" %% "play-plugins-mailer" % "2.0.2"``` to your dependencies (```project/Build.scala```)
+(requiring play 2.0.2)
+
+* add ```"com.typesafe" %% "play-plugins-mailer" % "2.0.3"``` to your dependencies (```project/Build.scala```)
* add ```1500:com.typesafe.plugin.CommonsMailerPlugin``` to your ```conf/play.plugins```
furthermore, the following parameters can be configured in ```conf/application.conf```
@@ -3,8 +3,8 @@ import Keys._
object MinimalBuild extends Build {
- lazy val buildVersion = "2.0.2"
- lazy val playVersion = "2.0.1"
+ lazy val buildVersion = "2.0.3"
+ lazy val playVersion = "2.0.2"
lazy val typesafeSnapshot = "Typesafe Snapshots Repository" at "http://repo.typesafe.com/typesafe/snapshots/"
lazy val typesafe = "Typesafe Repository" at "http://repo.typesafe.com/typesafe/releases/"
@@ -8,7 +8,7 @@ object ApplicationBuild extends Build {
val appVersion = "1.0-SNAPSHOT"
val appDependencies = Seq(
- "com.typesafe" %% "play-plugins-mailer" % "2.0"
+ "com.typesafe" %% "play-plugins-mailer" % "2.0.3-SNAPSHOT"
)
@@ -5,4 +5,4 @@ logLevel := Level.Warn
resolvers += "Typesafe repository" at "http://repo.typesafe.com/typesafe/releases/"
// Use the Play sbt plugin for Play projects
-addSbtPlugin("play" % "sbt-plugin" % "2.0")
+addSbtPlugin("play" % "sbt-plugin" % "2.1-SNAPSHOT")
View
@@ -9,9 +9,10 @@ small scala and java utilities that we are using across the board
* provides security implementation based on a request header and/or query parameter (Scala)
# How to install
+(requires play 2.0.2)
* add
-```"com.typesafe" % "play-plugins-util" % "2.0.1"``` to your dependencies
+```"com.typesafe" % "play-plugins-util" % "2.0.3"``` to your dependencies
## Licence
View
@@ -3,8 +3,8 @@ import Keys._
object MinimalBuild extends Build {
- lazy val buildVersion = "2.0.2"
- lazy val playVersion = "2.0.1"
+ lazy val buildVersion = "2.0.3"
+ lazy val playVersion = "2.0.2"
lazy val typesafeSnapshot = "Typesafe Snapshots Repository" at "http://repo.typesafe.com/typesafe/snapshots/"
lazy val typesafe = "Typesafe Repository" at "http://repo.typesafe.com/typesafe/releases/"
lazy val repo = if (buildVersion.endsWith("SNAPSHOT")) typesafeSnapshot else typesafe

0 comments on commit 7a539ad

Please sign in to comment.