Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[#1910] Fix Stacktrace when running play start with existing pid but no #839

Open
wants to merge 363 commits into
base: 1.3.x
from

Conversation

Projects
None yet
9 participants
@flybyray
Copy link
Contributor

commented Feb 15, 2015

Please close [#1860] and [#1896] as well.

xael-fry and others added some commits Mar 2, 2016

make ApplicationClassloader methods and fields less visible;
make allClasses, allClassesByNormalizedName, assignableClassesByName unmodifiable to avoid risk that somebody changes their content.
fix invalid usages of Play.classloader.getAssignableClasses(): it ret…
…urns unmodifiable list.

Nobody is allowed to add classes to it!
Merge pull request #970 from codeborne/1.4.x
make play.inject.Injector work with unmodifiable class lists
* [#2042] chore(deps): upgrade Play! dependencies:
** c3p0 from .9.5 to 0.9.5.2,
** ams-all from 5.0.4 to 5.1,
** h2 from 1.4.185 to 1.4.191,
** validation-api from 1.0.0.GA to 1.1.0.Final
** sr107cache from 1.0 to 1.1
** mysql from 5.1.35 to 5.1.38.
** bcprov-jdk15 from 1.45 to 1.46
** mchange-commons-java from 0.2.9 to 0.2.11
** avassist from 3.20.0-GA to 3.20.0-GA3.10.4.Final3.10.4.Final
** slf4j from 1.7.16 to 1.7.18,
** ant from 5.0.4 to 1.9.6,
Merge pull request #971 from xael-fry/2042_upgradeDeps
* [#2042] chore(deps): upgrade Play! dependencies:
Merge pull request #967 from codeborne/support-empty-variables-in-val…
…idation-error

[#2044] support empty values in validation error arguments
upgrade to cglib 3.2.2
* Play built-in cglib 3.2.1 has issues with Guice: cglib/cglib#61
* it was fixed in 3.2.2: https://github.com/cglib/cglib/releases/tag/RELEASE_3_2_2
Merge pull request #973 from xael-fry/2049_resultSetClose
* [#2049] fix(evolutions): Some resultsets are not close in Evolutions causing some leak
* [#2050] chore(lib): update slf4j-api from 1.7.18 to 1.7.21
* [#2050] chore(lib): update slf4j-log4j12 from  1.7.18 to 1.7.21
Merge pull request #975 from xael-fry/2050_updateNettyAsyncHttp
[#2050] chore(lib): update netty from 3.10.4 to 3.10.5

asolntsev and others added some commits May 8, 2017

[#2089] dependencies upgrade:
* com.h2database:h2 1.4.193 -->> 1.4.195
* joda-time 2.9.7 -- >> 2.9.9
* mysql:mysql-connector-java 5.1.40 -->> 5.1.41
Merge pull request #1131 from dejan2609/deps-upgrade
[#2089] dependencies upgrade:
Merge pull request #1136 from codeborne/upgrade-eclipse-compiler
upgrade to eclipse compiler 3.12.3
Merge pull request #1108 from codeborne/jobs-casting
Avoid casting when calling getPluginInstance()
Merge pull request #1139 from flybyray/lighthouse-2120-patch
[#2120] Add support for (special) hibernate properties through applic…
#1142 add parameter `--shortModuleNames` to `play deps` command
it creates modules directories without version numbers
Merge pull request #1143 from codeborne/shorten-module-names
#1142 add parameter `--shortModuleNames` to `play deps` command
@asolntsev

This comment has been minimized.

Copy link
Collaborator

commented May 22, 2017

@flybyray Do you still need this PR? Can you rebase it on master branch?

asolntsev added some commits May 24, 2017

Merge pull request #1141 from davidcostanzo/lighthouse-2121-patch
[#2121] Move _key() after reference/null checks in JPABase.equals()
try to upgrade hibernate
try to upgrade hibernate

next try

add missing dependency com.fasterxml -> classmate (used by hibernate 5)

set datasource to hibernate

fix dependencies.yml format

upgrade hibernate-c3p0 dependency

upgrade to hibernate 5.2.8

ApplicationClassloader can now find ".class" resources

without this, Hibernate5 would not resolve programmatically added entity classes

upgrade to hibernate 5.2.10

fix tests: use indexed placeholders for parameters

use patched version of hibernate-core 5.2.10

fix test

fix test

add support for "jpa.mapping-file" setting

rename to hibernate-core 5.2.10.patched
@flybyray

This comment has been minimized.

Copy link
Contributor Author

commented May 25, 2017

I will check changes in master.
The PR was just needed because of localization dependant code needed if someone uses non english windows
https://github.com/playframework/play1/pull/839/files#diff-158e4fe076b2af0296d71ca9d9f6eb7dR194

Andrei Solntsev, Marek Kusmin and others added some commits May 26, 2017

Merge pull request #1152 from codeborne/fix-hibernate5-in-precompiled…
…-mode

finds classes in precompiled folder too
@flybyray

This comment has been minimized.

[#1896] fix play daemon stacktrace on [re]start-stop
duplicates [#1910]
and fixes [#1860]

@flybyray flybyray force-pushed the synapplix:lighthouse-1910-patch branch from 8af9b37 to df26f71 May 30, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.