Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

0.62 hangs on Windows #4

Closed
mrmuskrat opened this Issue · 6 comments

2 participants

@mrmuskrat

At least with Windows 7 running Strawberry Perl 5.12.3... It's hanging after the is test on line 53 of t/on_fail.t but before the isa_ok test on line 60.

CPAN.pm: Building P/PL/PLICEASE/AnyEvent-Open3-Simple-0.62.tar.gz

cp lib/AnyEvent/Open3/Simple.pm blib\lib\AnyEvent\Open3\Simple.pm
cp lib/AnyEvent/Open3/Simple/Process.pm blib\lib\AnyEvent\Open3\Simple\Process.pm
(C:\strawberry\c\bin\dmake.EXE exited with 0)
CPAN::Reporter: dmake result is 'pass', No errors.
PLICEASE/AnyEvent-Open3-Simple-0.62.tar.gz
C:\strawberry\c\bin\dmake.EXE -- OK
Running make test
C:\strawberry\perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0,'blib\lib', 'blib\arch')" t/*.t
t/create.t ......... ok
t/defect_gh1.t ..... ok
t/on_error.t ....... skipped: test requires perl 5.14 or better
t/on_error_mock.t .. ok
# timeout!

# Failed test 'exit_value2 = 0'
# at t/on_fail.t line 53.
# got: undef
# expected: '0'

@plicease
Owner

I've adjusted the timeout failure in the tests for 0.63. If you can verify that the tests do not at least hang I would appreciate it.

@mrmuskrat

0.63 wasn't showing up on search.cpan.org or metacpan.org this weekend; it is now. I'll remove the disable file for this module from the cpan/prefs directory and restart my smokers tonight.

@mrmuskrat

My smoker setup wasn't pulling down the right version so I switched to a manual approach (I kept getting 0.62). Apparently the mirror(s) that the cpan command are using have not updated their index with 0.63. I was able to pull down 0.63 by using 'cpan PLICEASE\AnyEvent-Open3-Simple-0.63.tar.gz' though. I did this on the same machine as before (running Strawberry Perl 5.12.3 on Windows 7). It appears to be hanging up after skipping t/print.t.

C:\Users\mmusgrove\Desktop>cpan PLICEASE/AnyEvent-Open3-Simple-0.63.tar.gz
CPAN: CPAN::SQLite loaded ok (v0.202)
Database was generated on Mon, 04 Feb 2013 07:21:01 GMT
CPAN: YAML loaded ok (v0.84)
CPAN: CPAN::Kwalify loaded ok (v5.50)

______________________ D i s t r o P r e f s ______________________
                        00-disabled.yml[28]
Running make for P/PL/PLICEASE/AnyEvent-Open3-Simple-0.63.tar.gz
CPAN: LWP::UserAgent loaded ok (v6.04)
Fetching with LWP:
http://cpan.strawberryperl.com/authors/id/P/PL/PLICEASE/AnyEvent-Open3-Simple-0.
63.tar.gz
CPAN: Digest::SHA loaded ok (v5.82)
Fetching with LWP:
http://cpan.strawberryperl.com/authors/id/P/PL/PLICEASE/CHECKSUMS
CPAN: Compress::Zlib loaded ok (v2.055)
Checksum for C:\strawberry\cpan\sources\authors\id\P\PL\PLICEASE\AnyEvent-Open3-
Simple-0.63.tar.gz ok
CPAN: Archive::Tar loaded ok (v1.90)
CPAN: File::Temp loaded ok (v0.22)
CPAN: Parse::CPAN::Meta loaded ok (v1.4404)
CPAN: CPAN::Meta loaded ok (v2.120921)
CPAN: Module::CoreList loaded ok (v2.80)

  CPAN.pm: Building P/PL/PLICEASE/AnyEvent-Open3-Simple-0.63.tar.gz

CPAN: CPAN::Reporter loaded ok (v1.2009)
Checking if your kit is complete...
Looks good
Writing Makefile for AnyEvent::Open3::Simple
Writing MYMETA.yml and MYMETA.json
(C:\strawberry\perl\bin\perl.exe Makefile.PL exited with 0)
CPAN::Reporter: Makefile.PL result is 'pass', No errors.
cp lib/AnyEvent/Open3/Simple.pm blib\lib\AnyEvent\Open3\Simple.pm
cp lib/AnyEvent/Open3/Simple/Process.pm blib\lib\AnyEvent\Open3\Simple\Process.p
m
(C:\strawberry\c\bin\dmake.EXE exited with 0)
CPAN::Reporter: dmake result is 'pass', No errors.
  PLICEASE/AnyEvent-Open3-Simple-0.63.tar.gz
  C:\strawberry\c\bin\dmake.EXE -- OK
Running make test
C:\strawberry\perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0,
'blib\lib', 'blib\arch')" t/*.t
t/create.t ......... ok
t/defect_gh1.t ..... ok
t/on_error.t ....... skipped: test requires perl 5.14 or better
t/on_error_mock.t .. ok
# timeout!
# Looks like you planned 6 tests but ran 1.
# Looks like your test exited with 2 just after 1.
t/on_fail.t ........
Dubious, test returned 2 (wstat 512, 0x200)
Failed 5/6 subtests
# timeout!
# Looks like you planned 5 tests but ran 1.
# Looks like your test exited with 2 just after 1.
t/on_out.t .........
Dubious, test returned 2 (wstat 512, 0x200)
Failed 4/5 subtests
# timeout!
# Looks like you planned 6 tests but ran 1.
# Looks like your test exited with 2 just after 1.
t/on_signal.t ......
Dubious, test returned 2 (wstat 512, 0x200)
Failed 5/6 subtests
t/print.t .......... skipped: test broken on MSWin32
@plicease
Owner

Okay, looks like there was a timeout missing from t/proc.t which is where it was hanging. I had to install 5.12.3 in order to reproduce it, it didn't hang on 5.16.1, which is where I had done my original MSWin32 testing.

I've added a timeout and released 0.64. If I haven't tried your patience too much already I would appreciate if you could verify that does the trick. Thanks!

@mrmuskrat

That seems to have gotten rid of the issue that was causing it to hang on this version of Perl.

C:\Users\mmusgrove\Desktop>cpan PLICEASE/AnyEvent-Open3-Simple-0.64.tar.gz
CPAN: CPAN::SQLite loaded ok (v0.202)
Database was generated on Tue, 05 Feb 2013 08:00:02 GMT
CPAN: YAML loaded ok (v0.84)
CPAN: CPAN::Kwalify loaded ok (v5.50)

______________________ D i s t r o P r e f s ______________________
                        00-disabled.yml[28]
Running make for P/PL/PLICEASE/AnyEvent-Open3-Simple-0.64.tar.gz
CPAN: LWP::UserAgent loaded ok (v6.04)
Fetching with LWP:
http://cpan.strawberryperl.com/authors/id/P/PL/PLICEASE/AnyEvent-Open3-Simple-0.
64.tar.gz
LWP failed with code[404] message[Not Found]
Warning: no success downloading 'C:\strawberry\cpan\sources\authors\id\P\PL\PLIC
EASE\AnyEvent-Open3-Simple-0.64.tar.gz.tmp7744'. Giving up on it.
Fetching with LWP:
http://www.cpan.org/authors/id/P/PL/PLICEASE/AnyEvent-Open3-Simple-0.64.tar.gz
CPAN: Digest::SHA loaded ok (v5.82)
Fetching with LWP:
http://www.cpan.org/authors/id/P/PL/PLICEASE/CHECKSUMS
CPAN: Compress::Zlib loaded ok (v2.055)
Checksum for C:\strawberry\cpan\sources\authors\id\P\PL\PLICEASE\AnyEvent-Open3-
Simple-0.64.tar.gz ok
CPAN: Archive::Tar loaded ok (v1.90)
CPAN: File::Temp loaded ok (v0.22)
CPAN: Parse::CPAN::Meta loaded ok (v1.4404)
CPAN: CPAN::Meta loaded ok (v2.120921)
CPAN: Module::CoreList loaded ok (v2.80)

  CPAN.pm: Building P/PL/PLICEASE/AnyEvent-Open3-Simple-0.64.tar.gz

CPAN: CPAN::Reporter loaded ok (v1.2009)
Checking if your kit is complete...
Looks good
Writing Makefile for AnyEvent::Open3::Simple
Writing MYMETA.yml and MYMETA.json
(C:\strawberry\perl\bin\perl.exe Makefile.PL exited with 0)
CPAN::Reporter: Makefile.PL result is 'pass', No errors.
cp lib/AnyEvent/Open3/Simple.pm blib\lib\AnyEvent\Open3\Simple.pm
cp lib/AnyEvent/Open3/Simple/Process.pm blib\lib\AnyEvent\Open3\Simple\Process.p
m
(C:\strawberry\c\bin\dmake.EXE exited with 0)
CPAN::Reporter: dmake result is 'pass', No errors.
  PLICEASE/AnyEvent-Open3-Simple-0.64.tar.gz
  C:\strawberry\c\bin\dmake.EXE -- OK
Running make test
C:\strawberry\perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0,
'blib\lib', 'blib\arch')" t/*.t
t/create.t ......... ok
t/defect_gh1.t ..... ok
t/on_error.t ....... skipped: test requires perl 5.14 or better
t/on_error_mock.t .. ok
# timeout!
# Looks like you planned 6 tests but ran 1.
# Looks like your test exited with 2 just after 1.
t/on_fail.t ........
Dubious, test returned 2 (wstat 512, 0x200)
Failed 5/6 subtests
# timeout!
# Looks like you planned 5 tests but ran 1.
# Looks like your test exited with 2 just after 1.
t/on_out.t .........
Dubious, test returned 2 (wstat 512, 0x200)
Failed 4/5 subtests
# timeout!
# Looks like you planned 6 tests but ran 1.
# Looks like your test exited with 2 just after 1.
t/on_signal.t ......
Dubious, test returned 2 (wstat 512, 0x200)
Failed 5/6 subtests
t/print.t .......... skipped: test broken on MSWin32
# timeout!
# Looks like you planned 3 tests but ran 1.
# Looks like your test exited with 2 just after 1.
t/proc.t ...........
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/3 subtests
t/use.t ............ ok

Test Summary Report
-------------------
t/on_fail.t      (Wstat: 512 Tests: 1 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 6 tests but ran 1.
t/on_out.t       (Wstat: 512 Tests: 1 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 5 tests but ran 1.
t/on_signal.t    (Wstat: 512 Tests: 1 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 6 tests but ran 1.
t/proc.t         (Wstat: 512 Tests: 1 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 3 tests but ran 1.
Files=10, Tests=12, 21 wallclock secs ( 0.08 usr +  0.03 sys =  0.11 CPU)
Result: FAIL
Failed 4/10 test programs. 0/12 subtests failed.
dmake.EXE:  Error code 255, while making 'test_dynamic'
(C:\strawberry\c\bin\dmake.EXE test exited with 65280)
CPAN::Reporter: Test result is 'fail', One or more tests failed.
CPAN::Reporter: preparing a CPAN Testers report for AnyEvent-Open3-Simple-0.64
Do you want to review or edit the test report? (yes/no) [no]
Do you want to send the report? (yes/no) [yes]
CPAN::Reporter: sending test report with 'fail' via Metabase
  PLICEASE/AnyEvent-Open3-Simple-0.64.tar.gz
  C:\strawberry\c\bin\dmake.EXE test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
  reports PLICEASE/AnyEvent-Open3-Simple-0.64.tar.gz
Running make install
  make test had returned bad status, won't install without force
@plicease
Owner

cool, thanks! I'm going to close this issue, there is already another for the fact that it doesn't work under windows.

@plicease plicease closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.