Skip to content
Perl interface to the NetBSD editline library
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
example
fallback
inc/Alien/Base
lib/Term
maint
t
.gitattributes
.gitignore
.travis.yml
Changes
EditLine.xs
LICENSE
MANIFEST
MANIFEST.SKIP
Makefile.PL
README
ppport.h
typemap

README

Term::EditLine
==============

Term::EditLine is an object oriented perl interface to the NetBSD editline
library. To use the module you can install that library first, but it
can fall back to Alien::Editline if it's not present. Read
the pod documentation for more information on this module.

INSTALLATION

Install libedit if you want to use that option, for instance with this
command in Debian based distributions, including Ubuntu: 

    sudo apt install libedit-dev

Or, for RedHat-like distros

    sudo yum install libedit-devel

Install pkgconf with

    sudo apt install pkgconf
    
To install this module type the following:

    perl Makefile.PL
    make
    make install

DEPENDENCIES

This module requires these other modules and libraries:

libedit

COPYRIGHT AND LICENCE

Copyright (C) 2003 Ulrich Burgbacher

Copyright (C) 2014 Graham Ollis

This library is free software; you can redistribute it and/or modify
it under the same terms as Perl itself.
You can’t perform that action at this time.