Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

@sharing does not work on the plone site root #780

Closed
csenger opened this issue Jul 10, 2019 · 1 comment

Comments

@csenger
Copy link
Contributor

commented Jul 10, 2019

2019-07-10 09:27:11 ERROR Zope.SiteErrorLog 1562743631.070.120943757926 http://localhost:8080/Plone/@sharing
Traceback (innermost last):
  Module ZPublisher.Publish, line 138, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 48, in call_object
  Module plone.rest.service, line 23, in __call__
  Module plone.restapi.services, line 21, in render
  Module plone.restapi.services.content.sharing, line 60, in reply
  Module plone.restapi.deserializer.local_roles, line 58, in __call__
TypeError: ('Could not adapt', <PloneSite at /Plone>, <InterfaceClass Products.CMFCore.interfaces._content.ICatalogAware>)

The plone @@sharing view can be used on the site root and is calling .reindexObjectSecurity without checks for interfaces.

@csenger csenger self-assigned this Jul 10, 2019
@jensens

This comment has been minimized.

Copy link
Member

commented Sep 9, 2019

this one was fixed with #781

@jensens jensens closed this Sep 9, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.