Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

bump plotly.js to version 1.45.0 #470

Merged
merged 7 commits into from Mar 4, 2019
Merged
Changes from 5 commits
Commits
File filter...
Filter file types
Jump to…
Jump to file or symbol
Failed to load files and symbols.

Always

Just for now

@@ -2,6 +2,20 @@
All notable changes to this project will be documented in this file.
This project adheres to [Semantic Versioning](http://semver.org/).


## [Unreleased]
### Updated
- Upgraded plotly.js to 1.45.0 [#470](https://github.com/plotly/dash-core-components/pull/470)
- [Feature release 1.45.0](https://github.com/plotly/plotly.js/releases/tag/v1.45.0) which contains:
- Sankey diagram improvements including circular networks, node grouping, and concentration colorscales
- Matching cartesian axes
- Better bar, box, and violin alignment control
- Orthographic 3D projections
- Hovertemplate support for more trace types, including all 3D traces
- And many other features and bug fixes
- Patch releases [1.44.4](https://github.com/plotly/plotly.js/releases/tag/v1.44.4) containing numerous bug fixes

This comment has been minimized.

Copy link
@alexcjohnson

alexcjohnson Mar 1, 2019

Contributor

Patch release (s)



## [0.43.1] - 2019-02-11
### Updated
- Upgraded plotly.js to 1.44.3 [#458](https://github.com/plotly/dash-core-components/pull/458)
@@ -78,7 +78,7 @@ respectively. TODO:

## Updating Plotly.js

1. Download the latest plotly.js from the cdn: `$ wget https://cdn.plot.ly/plotly-1.44.3.min.js`
1. Download the latest plotly.js from the cdn: `$ wget https://github.com/plotly/plotly.js/releases/tag/v1.45.0`
2. Update `dash_core_components/__init__.py` plotly.js `external_url`
3. Update `MANIFEST.in`
4. Update `CHANGELOG.md` with links to the releases and a description of the changes. The message should state (see the existing `CHANGELOG.md` for examples):
@@ -5,7 +5,7 @@ include dash_core_components/dash_core_components.dev.js.map
include dash_core_components/metadata.json
include dash_core_components/rc-slider@6.1.2.css
include dash_core_components/react-select@1.0.0-rc.3.min.css
include dash_core_components/plotly-1.44.3.min.js
include dash_core_components/plotly-1.45.0.min.js
include dash_core_components/react-virtualized-select@3.1.0.css
include dash_core_components/react-virtualized@9.9.0.css
include dash_core_components/react-dates@12.3.0.css
@@ -35,8 +35,8 @@

_js_dist = [
{
'external_url': 'https://cdn.plot.ly/plotly-1.44.3.min.js',
'relative_package_path': 'plotly-1.44.3.min.js',
'external_url': 'https://cdn.plot.ly/plotly-1.45.0.min.js',
'relative_package_path': 'plotly-1.45.0.min.js',
'namespace': 'dash_core_components'
},
{

This file was deleted.

Large diffs are not rendered by default.

ProTip! Use n and p to navigate between commits in a pull request.
You can’t perform that action at this time.