Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Will not run on < PHP 7.0 #10

Closed
supergrecko opened this issue May 5, 2019 · 3 comments

Comments

Projects
None yet
2 participants
@supergrecko
Copy link
Contributor

commented May 5, 2019

Because parameter type hinting and parameter type hinting was released with PHP 7 the code will fail on anything below 7.0

@plumthedev plumthedev self-assigned this May 5, 2019

@plumthedev

This comment has been minimized.

Copy link
Owner

commented May 5, 2019

thanks for the feedback, that's true so I can resolve this issue in two ways. Change in readme requirements or add phpDoc blocks to support anything below 7.0

@supergrecko

This comment has been minimized.

Copy link
Contributor Author

commented May 5, 2019

I believe you should change the README requirements because PHP 5.x is deprecated and anybody should use PHP 7+ anyways.

@plumthedev

This comment has been minimized.

Copy link
Owner

commented May 5, 2019

@supergrecko thanks for good tip, in next commit I change this and close this issue, I encourage to follow me and star this library!

plumthedev added a commit that referenced this issue May 5, 2019

@plumthedev plumthedev closed this May 5, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.