Skip to content

v8.10.0

Compare
Choose a tag to compare
@github-actions github-actions released this 27 Oct 14:56
· 232 commits to main since this release
v8.10.0
3eeb16f

Minor Changes

  • Support for multiple architectures when installing dependencies #5965.

    You can now specify architectures for which you'd like to install optional dependencies, even if they don't match the architecture of the system running the install. Use the supportedArchitectures field in package.json to define your preferences.

    For example, the following configuration tells pnpm to install optional dependencies for Windows x64:

    {
      "pnpm": {
        "supportedArchitectures": {
          "os": ["win32"],
          "cpu": ["x64"]
        }
      }
    }

    Whereas this configuration will have pnpm install optional dependencies for Windows, macOS, and the architecture of the system currently running the install. It includes artifacts for both x64 and arm64 CPUs:

    {
      "pnpm": {
        "supportedArchitectures": {
          "os": ["win32", "darwin", "current"],
          "cpu": ["x64", "arm64"]
        }
      }
    }

    Additionally, supportedArchitectures also supports specifying the libc of the system.

  • The pnpm licenses list command now accepts the --filter option to check the licenses of the dependencies of a subset of workspace projects #5806.

Patch Changes

  • Allow scoped name as bin name #7112.

  • When running scripts recursively inside a workspace, the logs of the scripts are grouped together in some CI tools. (Only works with --workspace-concurrency 1)

  • Print a warning when installing a dependency from a non-existent directory #7159

  • Should fetch dependency from tarball url when patching dependency installed from git #7196

  • pnpm setup should add a newline at the end of the updated shell config file #7227.

  • Improved the performance of linking bins of hoisted dependencies to node_modules/.pnpm/node_modules/.bin #7212.

  • Wrongful ELIFECYCLE error on program termination #7164.

  • pnpm publish should not pack the same file twice sometimes #6997.

    The fix was to update npm-packlist to the latest version.

Our Gold Sponsors

Our Silver Sponsors