New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Podlove analytics stopped working in Firefox #1034

Open
rahra opened this Issue Feb 5, 2019 · 1 comment

Comments

Projects
None yet
1 participant
@rahra
Copy link

rahra commented Feb 5, 2019

Expected behavior

In the top section of the analytics page a nice colored diagram appears.

Actual behavior

The diagram disappeared yesterday without any apparent reason. It still works with Google Chrome but not with Firefox.

System information (see Podlove > Support menu)

The debugging console of Firefox shows the following:

JQMIGRATE: Migrate is installed, version 1.4.1 load-scripts.php:9:542
Loading failed for the <script> with source “https://www.XXX.at/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/js/dist/analytics.js?ver=1d19411b70905ae43390cb686ad51d5e”. admin.php:103:1
onmozfullscreenchange is deprecated. components.min.js:12:81117
onmozfullscreenerror is deprecated. components.min.js:12:81117
unreachable code after return statement[Learn More] wp-hide-post-admin.js:49:8

I use the latest Firefox Quantum 65.0 (64-bit) according to "About Mozilla Firefox".

Website                    https://www.freeskippers.at
PHP Version                7.2.14
WordPress Version          5.0.3
WordPress Theme            Twenty Fourteen v2.5
Active Plugins             
           - Antispam Bee v2.9.1
           - Crafty Social Buttons v1.5.8
           - Easy Facebook Likebox v4.3.9
           - Footnotation v1.2
           - Podlove Podcast Publisher v2.7.22
           - Podlove Subscribe Button v1.3.6
           - Simple Lightbox v2.7.0
           - TinyMCE Advanced v5.0.1
           - Yoast SEO v9.5
           - WP Hide Post v2.0.10
           - WP QuickLaTeX v3.8.6
           - NextGEN Gallery v3.1.6
WordPress Database Charset utf8
WordPress Database Collate 
Publisher Version          2.7.22
Web Player Version         player_v4
Twig Version               1.36.0
open_basedir               ok
curl Version               7.63.0
iconv                      available
simplexml                  ok
max_execution_time         30
upload_max_filesize        10M
memory_limit               512M
disable_classes            
disable_functions          
permalinks                 ok (/%year%/%monthnum%/%postname%/)
podlove_permalinks         ok
podcast_settings           ok
web_player                 ok
podlove_cache              on
assets                     
  - mp3    audio/mpeg       https://www.freeskippers.at/feed/mp3/
  - ogg    audio/ogg        https://www.freeskippers.at/feed/ogg/
cron                       ok

0 errors
0 notices
Nice, Everything looks fine!
@rahra

This comment has been minimized.

Copy link
Author

rahra commented Feb 5, 2019

Meanwhile I could track down this issue to the adblocker. I use Ublock origin and part of the analytics url matches an adblock rule (s. screenshot). Also Google Chrome behaves in the same way, yet.
Probably you should rename the URI to prevent this.
ublock

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment