Skip to content

WP 3.6 replaces line breaks with "rn" in Pods template editor #1584

Closed
OWMC opened this Issue Aug 2, 2013 · 11 comments

4 participants

@OWMC
OWMC commented Aug 2, 2013

When publishing changes to a pods template, the markup is rendered as one long line. It appears the line-breaks are replaced with "rn", which thus breaks the template.

@pglewis
Pods Foundation, Inc member
pglewis commented Aug 2, 2013

Also, in my testing, nothing but the title was loaded again after a save of the template. Unsure if the changes were not saved or just not loading properly after save.

@sc0ttkclark
Pods Foundation, Inc member

Noticing this happen in 3.6, must have something to do with the quoting changes. I hadn't seen this happen before on my previous 3.6 versions, so I've got some digging to do here.

@sc0ttkclark sc0ttkclark was assigned Aug 2, 2013
@ikrstic
ikrstic commented Aug 2, 2013

Same problem here, just a note that restoring to a previously saved version trough Revisions will display normally. also 3.6

@pglewis
Pods Foundation, Inc member
pglewis commented Aug 2, 2013

I'm not sure if this is one single issue or two separate ones yet... checking wp_posts on a template save without any newlines, I'm not getting anything in post_content.

Could also affect pages and other areas that would be tying into the new revision system, as an instinctive hunch.

@sc0ttkclark
Pods Foundation, Inc member

WP 3.6 introduced new slash handling between our last WP 3.6 test, the dev cycle for 3.6 went so long that it hadn't been changed until near the end.

@sc0ttkclark
Pods Foundation, Inc member

What version of PHP are you all running?

@pglewis
Pods Foundation, Inc member
pglewis commented Aug 2, 2013

My dev is: PHP 5.4.4, Apache 2.4, Win32

@OWMC
OWMC commented Aug 3, 2013

php 5.3.3, Apache 2.0 (i think), Linux

@ikrstic
ikrstic commented Aug 3, 2013

PHP 5.3.27, Apache 2.2.25, Linux

@sc0ttkclark
Pods Foundation, Inc member
@sc0ttkclark sc0ttkclark added a commit that closed this issue Aug 3, 2013
@sc0ttkclark sc0ttkclark WP 3.6 compatibility fixes with slashing, fixes #1584 and #1585
Fixes LIKE escaping to use pods_sanitize_like, fixes calls to
addslashes/stripslashes to use pods_slash/pods_unslash, changed
pods_sanitize to use wp_slash for WP 3.6 compatibility until we get
Pods core properly fixed to support the 3.6 changes to esc_sql now
using a real escape vs weak escape
49683db
@sc0ttkclark
Pods Foundation, Inc member

We're working on releasing 2.3.9 today or tomorrow, to get early access to it, just download the latest beta from http://pods.io/latest/

@sirbeagle sirbeagle pushed a commit that referenced this issue Sep 6, 2013
@sc0ttkclark sc0ttkclark WP 3.6 compatibility fixes with slashing, fixes #1584 and #1585
Fixes LIKE escaping to use pods_sanitize_like, fixes calls to
addslashes/stripslashes to use pods_slash/pods_unslash, changed
pods_sanitize to use wp_slash for WP 3.6 compatibility until we get
Pods core properly fixed to support the 3.6 changes to esc_sql now
using a real escape vs weak escape
9981d53
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.