Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Feature request": Info regarding WP 5.2 and PHP 7.3 support on wordpress.org. #5376

Open
oldrup opened this issue May 12, 2019 · 4 comments

Comments

@oldrup
Copy link

commented May 12, 2019

Hi! Thanks for a fantastic tool - I really enjoy it. However, reasonably complex as it its, I'm hesitating to update to the latest WordPress 5.2 and the in the new Site Health recommended PHP 7.3, as I can't find any information whether I can expect Pods Framework to be fully compatible with those releases.

I fact, according to wordpress.org, Pods Framework has only been tested compatible up to WordPress 5.0.4
https://wordpress.org/plugins/pods/

That said, I've been using Pods with WP 5.1.1 and PHP 7.2 in production for months, not encountering any issue. (Keeping in mind that my setup is simple with only a handful of pods and few relations)

Are there any "official" recommendations regarding updating to WordPress 5.2 and PHP 7.3?

Best regards
Bjarne Oldrup

@issue-label-bot

This comment has been minimized.

Copy link

commented May 12, 2019

Issue-Label Bot is automatically applying the label Type: Enhancement to this issue, with a confidence of 0.56. Please mark this comment with 👍 or 👎 to give our bot feedback!

Links: app homepage, dashboard and code for this bot.

@oldrup

This comment has been minimized.

Copy link
Author

commented May 14, 2019

To let you know, I've updated to WordPress 5.2 on a single site, and performed basic test, like adding, editing and viewing a custom posts. That did not reveal any critical issues.

@pglewis

This comment has been minimized.

Copy link
Collaborator

commented May 15, 2019

We're mostly just behind on documentation. The 2.8 branch actually requires a minimum of WordPress 5.2 right now; 2.7 will remain current as well if any issues are reported.

We should probably add PHP 7.3 to the Travis test matrix, I'll create an issue for that if there isn't one already.

@quasel quasel assigned quasel, sc0ttkclark and pglewis and unassigned quasel and sc0ttkclark May 16, 2019

@quasel quasel added this to the Pods 2.7.13 milestone May 16, 2019

@quasel quasel added this to Issue: Backlog in Maintenance Releases via automation May 16, 2019

@quasel

This comment has been minimized.

Copy link
Member

commented May 16, 2019

on my sites it runs flawless with php 7.3 bit it's currently not part of the travis-ci config… and we should update the readme to list it correctly on wp.org

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.